dbus: fix dbus symlink removal
authorDanomi Manchego <danomimanchego123@gmail.com>
Sat, 6 May 2017 00:51:18 +0000 (20:51 -0400)
committerPeter Korsgaard <peter@korsgaard.com>
Sat, 6 May 2017 08:55:02 +0000 (10:55 +0200)
There was already a post-build hook to delete the /var/lib/dbus symlink
created by buildroot after the package's own installation, to prevent
a dbus installation error during "make dbus-rebuild".  However, this
misses the case for when one might delete the .stamp_target_installed
file manually, outside of dbus-rebuild.  This can be fixed by changing
the post-build hook to a pre-install hook.  This seems appropriate,
since it is really addressing an installation issue, not a build issue.

Signed-off-by: Danomi Manchego <danomimanchego123@gmail.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/dbus/dbus.mk

index d333b203be0c2a560a8d26e885fbb214a66b41b9..ce4032994b24ca41c85edbac55d6e157eeae1d20 100644 (file)
@@ -82,7 +82,7 @@ define DBUS_REMOVE_VAR_LIB_DBUS
        rm -rf $(TARGET_DIR)/var/lib/dbus
 endef
 
-DBUS_POST_BUILD_HOOKS += DBUS_REMOVE_VAR_LIB_DBUS
+DBUS_PRE_INSTALL_TARGET_HOOKS += DBUS_REMOVE_VAR_LIB_DBUS
 
 define DBUS_REMOVE_DEVFILES
        rm -rf $(TARGET_DIR)/usr/lib/dbus-1.0