package/libglib2: fix NLS build on musl and uclibc
authorYann E. MORIN <yann.morin.1998@free.fr>
Mon, 24 Jun 2019 20:25:49 +0000 (22:25 +0200)
committerArnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Mon, 1 Jul 2019 08:00:27 +0000 (10:00 +0200)
libglib2 uses a very crude and error-prone way to detect the intl
functions, which basically fails when the C library is not glibc.

There is a bug report about this in upstream meson [1], but it doesn't
seem to get any progress. Fixing that properly in Buildroot looks
complicated.

Now that a meson package can specify its LDFLAGS, use that to pass the
infrastructure-provided TARGET_NLS_LIBS to link with.

Fixes:
    http://autobuild.buildroot.org/results/f0d/f0d85d76786343d767fba9c7c5c01f042ecfc018/
    [...]

[1] https://github.com/mesonbuild/meson/issues/3740

Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
Cc: Adam Duskett <aduskett@gmail.com>
Cc: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
package/libglib2/libglib2.mk

index 28a50f96a4d18d7aa68d101144b23b21b25b9538..28f404b74a168e5fcbf084da2a95f391c647155e 100644 (file)
@@ -12,6 +12,8 @@ LIBGLIB2_LICENSE = LGPL-2.1+
 LIBGLIB2_LICENSE_FILES = COPYING
 LIBGLIB2_INSTALL_STAGING = YES
 
+LIBGLIB2_LDFLAGS = $(TARGET_LDFLAGS) $(TARGET_NLS_LIBS)
+
 # glib/valgrind.h contains inline asm not compatible with thumb1
 ifeq ($(BR2_ARM_INSTRUCTIONS_THUMB),y)
 LIBGLIB2_CONF_ENV += CFLAGS="$(TARGET_CFLAGS) -marm"