gdb: add dependency on host-flex and host-bison for Git versions
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 5 Jul 2016 09:46:58 +0000 (11:46 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 5 Jul 2016 13:04:27 +0000 (15:04 +0200)
gdb versions fetched from git (such as the ARC version) will not build
with host-flex and host-bison.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Reviewed-by: Romain Naour <romain.naour@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/gdb/gdb.mk

index c9c6bd19581a7ca5e19738b185f5bd1652a27bcf..6d70955de0c6ec96610441dcd8fcbf503fcff2b8 100644 (file)
@@ -49,8 +49,8 @@ HOST_GDB_PRE_PATCH_HOOKS += GDB_XTENSA_PRE_PATCH
 endif
 
 ifeq ($(GDB_FROM_GIT),y)
-GDB_DEPENDENCIES += host-texinfo
-HOST_GDB_DEPENDENCIES += host-texinfo
+GDB_DEPENDENCIES += host-texinfo host-flex host-bison
+HOST_GDB_DEPENDENCIES += host-texinfo host-flex host-bison
 endif
 
 # When gdb sources are fetched from the binutils-gdb repository, they