alsa-utils: make fftw an optional dependency for alsabat
authorBaruch Siach <baruch@tkos.co.il>
Tue, 3 Jul 2018 04:29:36 +0000 (07:29 +0300)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Wed, 4 Jul 2018 20:04:16 +0000 (22:04 +0200)
The BR2_PACKAGE_ALSA_UTILS_BAT option currently selects
BR2_PACKAGE_FFTW. However, it turns out that fftw is not a mandatory
dependency to build alsabat, just an optional dependency.

This commit therefore turns this dependency into an optional
one. However, it is not just FFTW that is necessary, but the simple
precision version of FFTW, so the optional dependency takes this into
account.

We take this opportunity to extend the Config.in help text for
BR2_PACKAGE_ALSA_UTILS_BAT.

Cc: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Baruch Siach <baruch@tkos.co.il>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/alsa-utils/Config.in
package/alsa-utils/alsa-utils.mk

index 1a48fc0315efd722fede705f2f77e59aeac0ec02..edf5d39f2666bc94e8da2d6e05ff299276cedfc3 100644 (file)
@@ -76,7 +76,13 @@ config BR2_PACKAGE_ALSA_UTILS_ASEQNET
 
 config BR2_PACKAGE_ALSA_UTILS_BAT
        bool "bat"
-       select BR2_PACKAGE_FFTW
+       help
+         ALSABAT (ALSA Basic Audio Tester) is a simple command-line
+         utility intended to help automate audio driver and sound
+         server testing with little human interaction.
+
+         Note that analysis support in alsabat requires fftw single
+         precision.
 
 config BR2_PACKAGE_ALSA_UTILS_IECSET
        bool "iecset"
index 9b2e64b1d3e4a90804eabd13329e5dbb677b03bb..e9a45c675f9416df440460366890b0bd7330b7d8 100644 (file)
@@ -40,7 +40,8 @@ endif
 
 ifeq ($(BR2_PACKAGE_ALSA_UTILS_BAT),y)
 ALSA_UTILS_CONF_OPTS += --enable-bat
-ALSA_UTILS_DEPENDENCIES += fftw
+# Analysis support requires fftw single precision
+ALSA_UTILS_DEPENDENCIES += $(if $(BR2_PACKAGE_FFTW_PRECISION_SINGLE),fftw)
 else
 ALSA_UTILS_CONF_OPTS += --disable-bat
 endif