package/redis: bump to version 6.0.4
authorTitouan Christophe <titouan.christophe@railnova.eu>
Tue, 2 Jun 2020 10:40:08 +0000 (12:40 +0200)
committerYann E. MORIN <yann.morin.1998@free.fr>
Fri, 5 Jun 2020 22:16:09 +0000 (00:16 +0200)
- Update dependencies in Config.in because of new requirements
- Update the help text in Config.in to a more recent wording
- Update the hash file to the new 2 spaces convention

Signed-off-by: Titouan Christophe <titouan.christophe@railnova.eu>
[yann.morin.1998@free.fr:
  - rewrap help text
  - wrap long depends line in comment
]
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
package/redis/Config.in
package/redis/redis.hash
package/redis/redis.mk

index 2450ccdf7f4dd45141ceeb55b2e37cecd5028710..a2239b4a5464c6702a776bd0cd47a363c9aa6719 100644 (file)
@@ -2,16 +2,21 @@ config BR2_PACKAGE_REDIS
        bool "redis"
        depends on BR2_USE_MMU # fork()
        depends on !BR2_STATIC_LIBS # dlfcn.h
+       depends on BR2_TOOLCHAIN_GCC_AT_LEAST_4_9 # _Atomic keyword
        depends on BR2_TOOLCHAIN_HAS_ATOMIC
-       depends on BR2_TOOLCHAIN_HAS_THREADS
+       depends on BR2_TOOLCHAIN_HAS_THREADS_NPTL # pthread_setname_np()
        help
-         Redis is an open source, advanced key-value store. It is
-         often referred to as a data structure server since keys can
-         contain strings, hashes, lists, sets and sorted sets.
+         Redis is an open source (BSD licensed), in-memory data
+         structure store, used as a database, cache and message
+         broker. It supports data structures such as strings,
+         hashes, lists, sets, sorted sets with range queries,
+         bitmaps, hyperloglogs, geospatial indexes with radius
+         queries and streams.
 
          http://www.redis.io
 
-comment "redis needs a toolchain w/ dynamic library, threads"
+comment "redis needs a toolchain w/ gcc>=4.9, dynamic library, nptl"
        depends on BR2_USE_MMU
        depends on BR2_TOOLCHAIN_HAS_ATOMIC
-       depends on BR2_STATIC_LIBS || !BR2_TOOLCHAIN_HAS_THREADS
+       depends on BR2_STATIC_LIBS || !BR2_TOOLCHAIN_HAS_THREADS_NPTL \
+               || !BR2_TOOLCHAIN_GCC_AT_LEAST_4_9
index ee15b75e083d6ef010527db150e25bbc6fabd8db..cf13bb9c0a42979bcde863c90d4a88b7401465ed 100644 (file)
@@ -1,5 +1,5 @@
 # From https://github.com/antirez/redis-hashes/blob/master/README
-sha256 f3c7eac42f433326a8d981b50dba0169fdfaf46abb23fcda2f933a7552ee4ed7  redis-5.0.8.tar.gz
+sha256  3337005a1e0c3aa293c87c313467ea8ac11984921fab08807998ba765c9943de  redis-6.0.4.tar.gz
 
 # Locally calculated
-sha256 cbf420a3672475a6e2765e3c0984c1f81efe0212afb94a3c998ee63bfd661063  COPYING
+sha256  cbf420a3672475a6e2765e3c0984c1f81efe0212afb94a3c998ee63bfd661063  COPYING
index d3954d87caa4cd3fdad955f2fe18ce152dbbafe5..1578f97e0d39fd48c15442c2071853da76c88227 100644 (file)
@@ -4,7 +4,7 @@
 #
 ################################################################################
 
-REDIS_VERSION = 5.0.8
+REDIS_VERSION = 6.0.4
 REDIS_SITE = http://download.redis.io/releases
 REDIS_LICENSE = BSD-3-Clause (core); MIT and BSD family licenses (Bundled components)
 REDIS_LICENSE_FILES = COPYING