projects
/
buildroot.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
22c8b9f
)
package/linknx: add lua as optional dependency
author
Bernd Kuhls
<bernd.kuhls@t-online.de>
Fri, 1 Dec 2017 19:09:57 +0000
(20:09 +0100)
committer
Thomas Petazzoni
<thomas.petazzoni@free-electrons.com>
Fri, 1 Dec 2017 21:39:07 +0000
(22:39 +0100)
Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/linknx/linknx.mk
patch
|
blob
|
history
diff --git
a/package/linknx/linknx.mk
b/package/linknx/linknx.mk
index 7965ce4e16ddebafadb8dde053f6e33a45f856b4..dfabef550ebb89aa803236f153428d86dc1cd4ef 100644
(file)
--- a/
package/linknx/linknx.mk
+++ b/
package/linknx/linknx.mk
@@
-9,7
+9,6
@@
LINKNX_SITE = $(call github,linknx,linknx,$(LINKNX_VERSION))
LINKNX_LICENSE = GPL-2.0+
LINKNX_INSTALL_STAGING = YES
LINKNX_CONF_OPTS = \
- --without-lua \
--without-log4cpp \
--without-pth-test \
--with-pth=$(STAGING_DIR)/usr \
@@
-25,6
+24,13
@@
else
LINKNX_CONF_OPTS += --without-libcurl
endif
+ifeq ($(BR2_PACKAGE_LUA),y)
+LINKNX_CONF_OPTS += --with-lua
+LINKNX_DEPENDENCIES += lua
+else
+LINKNX_CONF_OPTS += --without-lua
+endif
+
ifeq ($(BR2_PACKAGE_MYSQL),y)
LINKNX_CONF_OPTS += --with-mysql=$(STAGING_DIR)/usr
LINKNX_DEPENDENCIES += mysql