Revert "busybox: added linux-pam support"
authorBaruch Siach <baruch@tkos.co.il>
Mon, 20 Jul 2015 12:57:55 +0000 (15:57 +0300)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 20 Jul 2015 13:11:38 +0000 (15:11 +0200)
This reverts commit 083aeac94e19cde6abd4b29cf29db589327d8c49.

Commit f21b2558a097 (busybox: added linux-pam support, 2015-06-02) added
linux-pam support already, no need to do this again. Commit 083aeac94e19
(busybox: added linux-pam support, 2015-07-14) also effectively annulled the
build failure fix from commit 98e1848db11e (busybox: PAM support needs thread
support, 2015-07-04). Revert it.

Fixes:
http://autobuild.buildroot.net/results/8df/8df14bde19a41b78aa6422a1649a570914f747ee/
http://autobuild.buildroot.net/results/30d/30dd11b576b590de513031fce5e034353f2f5544/
http://autobuild.buildroot.net/results/de6/de628d84b0ed49be8f5d021c789357b2e66f2b02/

Signed-off-by: Baruch Siach <baruch@tkos.co.il>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/busybox/busybox.mk

index ce6652b017d73cc8fa1ad26c91af4833add14dcd..65ce7efe95e1d13470beb35ae0b4388c6435538d 100644 (file)
@@ -141,13 +141,6 @@ define BUSYBOX_SET_INIT
 endef
 endif
 
-ifeq ($(BR2_PACKAGE_LINUX_PAM),y)
-define BUSYBOX_LINUX_PAM
-       $(call KCONFIG_ENABLE_OPT,CONFIG_PAM,$(BUSYBOX_BUILD_CONFIG))
-endef
-BUSYBOX_DEPENDENCIES += linux-pam
-endif
-
 ifeq ($(BR2_PACKAGE_BUSYBOX_SELINUX),y)
 BUSYBOX_DEPENDENCIES += host-pkgconf libselinux libsepol
 define BUSYBOX_SET_SELINUX