package/makedevs: define extract step to allow patching
authorPeter Korsgaard <peter@korsgaard.com>
Mon, 26 Apr 2021 21:46:26 +0000 (23:46 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Wed, 28 Apr 2021 21:44:27 +0000 (23:44 +0200)
As recently discussed on the list:
http://lists.busybox.net/pipermail/buildroot/2021-April/308373.html

Packages like makedevs where the source code is included in the Buildroot
tree, currently doesn't use an extract step (which also skips the patch
step), so they cannot be patched by a patch in BR2_GLOBAL_PATCH_DIR (or the
pkgdir), which is a bit confusing.

As a fix, add a simple extract step that copies the source file to the build
directory, so the patch step gets run as well.

Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/makedevs/makedevs.mk

index 36837a191e8729d53af9116ccaca38b08701c639..9b0f44610c06c020eb16c7e21e62b545f73b5f64 100644 (file)
@@ -15,8 +15,12 @@ HOST_MAKEDEVS_CFLAGS += -DEXTENDED_ATTRIBUTES
 HOST_MAKEDEVS_LDFLAGS += -lcap
 endif
 
+define HOST_MAKEDEVS_EXTRACT_CMDS
+       cp $(HOST_MAKEDEVS_PKGDIR)/makedevs.c $(@D)
+endef
+
 define HOST_MAKEDEVS_BUILD_CMDS
-       $(HOSTCC) $(HOST_MAKEDEVS_CFLAGS) package/makedevs/makedevs.c \
+       $(HOSTCC) $(HOST_MAKEDEVS_CFLAGS) $(@D)/makedevs.c \
                -o $(@D)/makedevs $(HOST_MAKEDEVS_LDFLAGS)
 endef