package: add libfcgi fast cgi library.
authorRico Bachmann <bachmann@tofwerk.com>
Fri, 14 Oct 2011 09:16:34 +0000 (11:16 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Sun, 29 Apr 2012 18:37:58 +0000 (20:37 +0200)
Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Signed-off-by: Rico Bachmann <bachmann@tofwerk.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/Config.in
package/libfcgi/Config.in [new file with mode: 0644]
package/libfcgi/libfcgi.mk [new file with mode: 0644]

index 4dcae531ea4468ff2514d984dbe5496572d6f2b8..2ea334a94e3192ec116724b3116248707157436c 100644 (file)
@@ -359,6 +359,7 @@ source "package/libcurl/Config.in"
 source "package/libdnet/Config.in"
 source "package/libesmtp/Config.in"
 source "package/libeXosip2/Config.in"
+source "package/libfcgi/Config.in"
 source "package/libidn/Config.in"
 source "package/liboauth/Config.in"
 source "package/libmicrohttpd/Config.in"
diff --git a/package/libfcgi/Config.in b/package/libfcgi/Config.in
new file mode 100644 (file)
index 0000000..a622ec3
--- /dev/null
@@ -0,0 +1,6 @@
+config BR2_PACKAGE_LIBFCGI
+       bool "libfcgi"
+       help
+         FCGI, a fastcgi developer library for C/C++
+
+         http://www.fastcgi.com/
diff --git a/package/libfcgi/libfcgi.mk b/package/libfcgi/libfcgi.mk
new file mode 100644 (file)
index 0000000..4625165
--- /dev/null
@@ -0,0 +1,12 @@
+##############################################################################
+#
+# libfcgi
+#
+##############################################################################
+LIBFCGI_VERSION = 2.4.0
+LIBFCGI_SOURCE = fcgi-$(LIBFCGI_VERSION).tar.gz
+LIBFCGI_SITE = http://www.fastcgi.com/dist
+LIBFCGI_INSTALL_STAGING = YES
+LIBFCGI_CONF_ENV = LDFLAGS="$(TARGET_LDFLAGS) -lm"
+
+$(eval $(call AUTOTARGETS))