bind: version bump to 9.6-ESV-R5 and server option
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Sat, 15 Oct 2011 03:07:31 +0000 (00:07 -0300)
committerPeter Korsgaard <jacmet@sunsite.dk>
Sat, 15 Oct 2011 21:19:15 +0000 (23:19 +0200)
Bump to version 9.6-ESV-R5.
Also add the server option in case users just want the tools.

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/bind/Config.in
package/bind/bind.mk

index 827ee261f05a2a731c808f05f8333860ce38e750..9b9c7eeb7d359b31168dae94af27ee1f2386499f 100644 (file)
@@ -1,5 +1,6 @@
 config BR2_PACKAGE_BIND
        bool "bind"
+       depends on BR2_INET_IPV6
        depends on BR2_LARGEFILE
        help
          BIND (Berkeley Internet Name Domain) is an implementation of
@@ -21,11 +22,20 @@ config BR2_PACKAGE_BIND
 
          http://www.isc.org/sw/bind/
 
+if BR2_PACKAGE_BIND
+
+config BR2_PACKAGE_BIND_SERVER
+       bool "Install server components"
+       default y
+       help
+         Install server components (named, lwresd)
+
 config BR2_PACKAGE_BIND_TOOLS
        bool "Install tools"
-       depends on BR2_PACKAGE_BIND
        help
          Install tools (host, nslookup, dig, nsupdate)
 
-comment "bind requires a toolchain with LARGEFILE support"
-       depends on !BR2_LARGEFILE
+endif
+
+comment "bind requires a toolchain with LARGEFILE and IPV6 support"
+       depends on !(BR2_LARGEFILE || BR2_INET_IPV6)
index b62c8ea0366cfcdb3a10be58eab6c45700e330d7..4c7a612394599ded6411942303367268de6b79f0 100644 (file)
@@ -4,7 +4,7 @@
 #
 #############################################################
 
-BIND_VERSION = 9.6-ESV-R4
+BIND_VERSION = 9.6-ESV-R5
 BIND_SITE = ftp://ftp.isc.org/isc/bind9/$(BIND_VERSION)
 BIND_MAKE = $(MAKE1)
 BIND_TARGET_SBINS = lwresd named named-checkconf named-checkzone
@@ -40,17 +40,25 @@ endef
 
 BIND_POST_INSTALL_TARGET_HOOKS += BIND_TARGET_INSTALL_FIXES
 
+define BIND_TARGET_REMOVE_SERVER
+       rm -rf $(addprefix $(TARGET_DIR)/usr/sbin/, $(BIND_TARGET_SBINS))
+endef
+
 define BIND_TARGET_REMOVE_TOOLS
        rm -rf $(addprefix $(TARGET_DIR)/usr/bin/, $(BIND_TARGET_BINS))
 endef
 
+ifneq ($(BR2_PACKAGE_BIND_SERVER),y)
+BIND_POST_INSTALL_TARGET_HOOKS += BIND_TARGET_REMOVE_SERVER
+endif
+
 ifneq ($(BR2_PACKAGE_BIND_TOOLS),y)
 BIND_POST_INSTALL_TARGET_HOOKS += BIND_TARGET_REMOVE_TOOLS
 endif
 
 define BIND_UNINSTALL_TARGET_CMDS
-       rm -rf $(addprefix $(TARGET_DIR)/usr/sbin/, $(BIND_TARGET_SBINS))
-       rm -rf $(addprefix $(TARGET_DIR)/usr/bin/, $(BIND_TARGET_BINS))
+       $(BIND_TARGET_REMOVE_SERVER)
+       $(BIND_TARGET_REMOVE_TOOLS)
        rm -rf $(addprefix $(TARGET_DIR)/usr/lib/, $(BIND_TARGET_LIBS))
        rm -f $(TARGET_DIR)/etc/init.d/S81named
 endef