lxc: enable lua if package is selected
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Sun, 18 Dec 2016 11:04:52 +0000 (12:04 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 18 Dec 2016 11:32:11 +0000 (12:32 +0100)
lua and python bindings were removed with the same patch:
https://patchwork.ozlabs.org/patch/367361. There is a real issue with
python but not with lua so enable it if lua is selected

Signed-off-by: Fabrice Fontaine <fabrice.fontaine@orange.com>
[Thomas: simplify value passed to --with-lua-pc.]
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/lxc/lxc.mk

index 589930f1a149003d817f940e810bb9d7c0e4b5c6..e9e925f4403d1997c11ac62051a1885a004a4b05 100644 (file)
@@ -10,7 +10,7 @@ LXC_LICENSE = LGPLv2.1+
 LXC_LICENSE_FILES = COPYING
 LXC_DEPENDENCIES = libcap host-pkgconf
 LXC_CONF_OPTS = --disable-apparmor --with-distro=buildroot \
-       --disable-lua --disable-python --disable-werror \
+       --disable-python --disable-werror \
        $(if $(BR2_PACKAGE_BASH),,--disable-bash)
 
 ifeq ($(BR2_PACKAGE_LIBSECCOMP),y)
@@ -20,4 +20,15 @@ else
 LXC_CONF_OPTS += --disable-seccomp
 endif
 
+ifeq ($(BR2_PACKAGE_HAS_LUAINTERPRETER),y)
+LXC_CONF_OPTS += --enable-lua
+LXC_DEPENDENCIES += luainterpreter
+ifeq ($(BR2_PACKAGE_LUAJIT),y)
+# By default, lxc will only search for lua.pc
+LXC_CONF_OPTS += --with-lua-pc=luajit
+endif
+else
+LXC_CONF_OPTS += --disable-lua
+endif
+
 $(eval $(autotools-package))