perl-gdgraph: new package
authorFrancois Perrad <fperrad@gmail.com>
Fri, 18 Jul 2014 13:43:39 +0000 (15:43 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Fri, 18 Jul 2014 17:49:37 +0000 (19:49 +0200)
Signed-off-by: Francois Perrad <francois.perrad@gadz.org>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/Config.in
package/perl-gdgraph/Config.in [new file with mode: 0644]
package/perl-gdgraph/perl-gdgraph.mk [new file with mode: 0644]

index 701b021ca282c9e359390ad4adf26fc7bcc2764c..15911c90e23741317b70ffed78ca42e213ac035f 100644 (file)
@@ -431,6 +431,7 @@ endif
 if BR2_PACKAGE_PERL
 menu "Perl libraries/modules"
        source "package/perl-gd/Config.in"
+       source "package/perl-gdgraph/Config.in"
        source "package/perl-gdtextutil/Config.in"
        source "package/perl-io-socket-ssl/Config.in"
        source "package/perl-mojolicious/Config.in"
diff --git a/package/perl-gdgraph/Config.in b/package/perl-gdgraph/Config.in
new file mode 100644 (file)
index 0000000..e722c06
--- /dev/null
@@ -0,0 +1,12 @@
+config BR2_PACKAGE_PERL_GDGRAPH
+       bool "perl-gdgraph"
+       depends on !BR2_PREFER_STATIC_LIB
+       select BR2_PACKAGE_PERL_GD
+       select BR2_PACKAGE_PERL_GDTEXTUTIL
+       help
+         Produces charts with GD
+
+         https://metacpan.org/release/GDGraph
+
+comment "perl-gdgraph needs a toolchain w/ dynamic library"
+       depends on BR2_PREFER_STATIC_LIB
diff --git a/package/perl-gdgraph/perl-gdgraph.mk b/package/perl-gdgraph/perl-gdgraph.mk
new file mode 100644 (file)
index 0000000..856c91c
--- /dev/null
@@ -0,0 +1,14 @@
+################################################################################
+#
+# perl-gdgraph
+#
+################################################################################
+
+PERL_GDGRAPH_VERSION = 1.48
+PERL_GDGRAPH_SOURCE = GDGraph-$(PERL_GDGRAPH_VERSION).tar.gz
+PERL_GDGRAPH_SITE = $(BR2_CPAN_MIRROR)/authors/id/R/RU/RUZ/
+PERL_GDGRAPH_DEPENDENCIES = perl perl-gd perl-gdtextutil
+PERL_GDGRAPH_LICENSE = Artistic or GPLv1+
+PERL_GDGRAPH_LICENSE_FILES = Dustismo.LICENSE
+
+$(eval $(perl-package))