uclibc: cleanup handling of ARC uClibc version
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 14 Feb 2015 21:01:05 +0000 (22:01 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Fri, 20 Feb 2015 08:45:51 +0000 (09:45 +0100)
This commit makes the ARC uClibc version handling explicit by adding a
BR2_UCLIBC_VERSION_ARC_GIT option, rather than only relying on the
selected architecture. This is needed in preparation to the
introduction of uClibc-ng support, which also supports the ARC
architecture: so we will now have two uClibc versions capable of
handling ARC.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Acked-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
package/uclibc/Config.in
package/uclibc/uclibc.mk

index aa99a6f1f6caefc59cd5e0368af4014a3550d328..a20b002f4dcb3ce51d45cf6eb99ea651fce391f7 100644 (file)
@@ -17,6 +17,10 @@ choice
                bool "uClibc 0.9.33.x"
                depends on !(BR2_arc || BR2_xtensa)
 
+       config BR2_UCLIBC_VERSION_ARC_GIT
+               bool "uClibc Git ARC"
+               depends on BR2_arc
+
        config BR2_UCLIBC_VERSION_XTENSA_GIT
                bool "uClibc Git Xtensa"
                depends on BR2_xtensa
@@ -37,14 +41,14 @@ config BR2_USE_UCLIBC_SNAPSHOT
 config BR2_UCLIBC_VERSION_STRING
        string
        default 0.9.33.2        if BR2_UCLIBC_VERSION_0_9_33
-       default "arc-2014.12" if BR2_arc
+       default "arc-2014.12" if BR2_UCLIBC_VERSION_ARC_GIT
        default "7bf35c8b7d4a1f97174eb49f47f33946b282114c" if BR2_UCLIBC_VERSION_XTENSA_GIT
        default BR2_USE_UCLIBC_SNAPSHOT if BR2_UCLIBC_VERSION_SNAPSHOT
 
 config BR2_UCLIBC_CONFIG
        string "uClibc configuration file to use?"
        default "package/uclibc/uClibc-0.9.33.config" if BR2_UCLIBC_VERSION_0_9_33
-       default "package/uclibc/uClibc-snapshot.config" if BR2_arc
+       default "package/uclibc/uClibc-snapshot.config" if BR2_UCLIBC_VERSION_ARC_GIT
        default "package/uclibc/uClibc-snapshot.config" if BR2_UCLIBC_VERSION_SNAPSHOT
        default "package/uclibc/uClibc-snapshot.config" if BR2_UCLIBC_VERSION_XTENSA_GIT
        help
index 40e6c6c171386cb3da1027fdf9be47829e520af7..b29cff4723c4e6db501eadf9b3e51a4c3e51e997 100644 (file)
@@ -11,7 +11,7 @@ UCLIBC_LICENSE_FILES = COPYING.LIB
 
 ifeq ($(BR2_UCLIBC_VERSION_SNAPSHOT),y)
 UCLIBC_SITE = http://www.uclibc.org/downloads/snapshots
-else ifeq ($(BR2_arc),y)
+else ifeq ($(BR2_UCLIBC_VERSION_ARC_GIT),y)
 UCLIBC_SITE = $(call github,foss-for-synopsys-dwc-arc-processors,uClibc,$(UCLIBC_VERSION))
 UCLIBC_SOURCE = uClibc-$(UCLIBC_VERSION).tar.gz
 else ifeq ($(BR2_UCLIBC_VERSION_XTENSA_GIT),y)