package/ibrdtnd: fix build with gcc 11
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Sun, 1 Aug 2021 08:09:28 +0000 (10:09 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sun, 1 Aug 2021 09:36:53 +0000 (11:36 +0200)
Fixes:
 - No autobuilder failures yet

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/ibrdtnd/ibrdtnd.mk

index 0632ed36b7db899120f82a2fc90445612d0447ca..20ac496fee6ba177100f9ab2047d48f2d8b34554 100644 (file)
@@ -18,7 +18,9 @@ IBRDTND_CONF_OPTS = \
        --without-vmime
 
 # don't build documentation
-IBRDTND_CONF_ENV = PDFLATEX='no'
+IBRDTND_CONF_ENV = \
+       PDFLATEX='no' \
+       CXXFLAGS="$(TARGET_CXXFLAGS) -std=c++11"
 
 ifeq ($(BR2_PACKAGE_LIBDAEMON),y)
 IBRDTND_CONF_OPTS += --enable-libdaemon