gst1-validate: needs python
authorPeter Seiderer <ps.report@gmx.net>
Thu, 13 Nov 2014 20:02:32 +0000 (21:02 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 22 Nov 2014 19:18:59 +0000 (20:18 +0100)
If host installed python version is < 2.7.0 gst1-validate compile will fail with

checking for a Python interpreter with version >= 2.7.0... none
configure: error: no suitable Python interpreter found

Fixed by adding host-python dependency.

Target tool /usr/bin/gst-validate-launcher is a python2 script

$ head -1 /usr/bin/gst-validate-launcher
#!/usr/bin/env python2

(and not easily upgradable to python3) so add python2 dependency and to fix
the following runtime error

$ gst-validate-launcher
Traceback (most recent call last):
  File "/usr/bin/gst-validate-launcher", line 44, in <module>
    from launcher.main import main
  File "/usr/lib/gst-validate-launcher/python/launcher/main.py", line 26, in <module>
    import reporters
  File "/usr/lib/gst-validate-launcher/python/launcher/reporters.py", line 29, in <module>
    from xml.sax import saxutils
ImportError: No module named xml.sax

add additional BR2_PACKAGE_PYTHON_PYEXPAT select.

Fixes:
 http://autobuild.buildroot.net/results/e8c/e8c27db2a0935c2daef173d5650f6a2b3a219493/
 http://autobuild.buildroot.net/results/723/723fe3036e8f0af2a90ff9e98173387466655000/

Signed-off-by: Peter Seiderer <ps.report@gmx.net>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/gstreamer1/gst1-validate/Config.in
package/gstreamer1/gst1-validate/gst1-validate.mk

index ffcdd270a5ef4f0940f0eef03b72c0ab26004221..34ec85ff4a09ea46d418250440c87961ceadb57b 100644 (file)
@@ -1,9 +1,14 @@
-menuconfig BR2_PACKAGE_GST1_VALIDATE
+config BR2_PACKAGE_GST1_VALIDATE
        bool "gst1-validate"
+       depends on BR2_PACKAGE_PYTHON
        select BR2_PACKAGE_GST1_PLUGINS_BASE
+       select BR2_PACKAGE_PYTHON_PYEXPAT
        help
          GstValidate is a tool that allows GStreamer developers to
          check that the GstElements they write behave the way they
          are supposed to.
 
          http://gstreamer.freedesktop.org/
+
+comment "gst1-validate depends on python"
+       depends on !BR2_PACKAGE_PYTHON
index 4972cacb6eeaa80fb574306d7cb214f1f3956f92..9a9e796aa958d4f129c43e187acc808ac1856a3c 100644 (file)
@@ -12,6 +12,6 @@ GST1_VALIDATE_LICENSE_FILES = COPYING
 
 GST1_VALIDATE_CONF_OPTS = --disable-sphinx-doc
 
-GST1_VALIDATE_DEPENDENCIES = gstreamer1 gst1-plugins-base
+GST1_VALIDATE_DEPENDENCIES = gstreamer1 gst1-plugins-base host-python python
 
 $(eval $(autotools-package))