tinyhttpd: do not link against pthread
authorgilles.talis@gmail.com <gilles.talis@gmail.com>
Fri, 21 Jun 2013 17:59:44 +0000 (10:59 -0700)
committerPeter Korsgaard <jacmet@sunsite.dk>
Sun, 23 Jun 2013 19:47:15 +0000 (21:47 +0200)
Original patch for tinyhttpd disables pthread support from the code
but does not disable it from makefile.
This patch disables pthread support altogether

Fixes:
http://autobuild.buildroot.net/results/2e61a80fcbddd62c76e0406c34ab44d14a4b5c79

Signed-off-by: Gilles Talis <gilles.talis@gmail.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/tinyhttpd/tinyhttpd.patch

index 02eb189af0639603df73025d977ac6de1f6592c0..05d6e50a70d9fa1d92e0f472b725564deb0c1683 100644 (file)
@@ -73,7 +73,7 @@ diff -ur tinyhttpd-0.1.0/Makefile tinyhttpd-0.1.0-patched/Makefile
  
  httpd: httpd.c
 -      gcc -W -Wall -lsocket -lpthread -o httpd httpd.c
-+      $(CC) $(CFLAGS) $(LDFLAGS) -W -Wall -lpthread -o httpd httpd.c
++      $(CC) $(CFLAGS) $(LDFLAGS) -W -Wall -o httpd httpd.c
  
  clean:
 -      rm httpd