wine: Add xlib_libXext dependency
authorAndré Hentschel <nerv@dawncrow.de>
Sat, 21 Mar 2015 15:38:27 +0000 (16:38 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Fri, 3 Apr 2015 22:18:15 +0000 (00:18 +0200)
This fixes window size issues.

Signed-off-by: André Hentschel <nerv@dawncrow.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/wine/wine.mk

index bd242cffb0ef3aa78d5689054f62d921a6eca8f0..188c7cc10e8672e012b12bf100fb4bd0965fdf97 100644 (file)
@@ -27,9 +27,7 @@ WINE_CONF_OPTS = \
        --without-openal \
        --without-opencl \
        --without-osmesa \
-       --without-oss \
-       --without-xshape \
-       --without-xshm
+       --without-oss
 
 # Wine uses a wrapper around gcc, and uses the value of --host to
 # construct the filename of the gcc to call.  But for external
@@ -207,6 +205,13 @@ else
 WINE_CONF_OPTS += --without-xcursor
 endif
 
+ifeq ($(BR2_PACKAGE_XLIB_LIBXEXT),y)
+WINE_CONF_OPTS += --with-xshape --with-xshm
+WINE_DEPENDENCIES += xlib_libXext
+else
+WINE_CONF_OPTS += --without-xshape --without-xshm
+endif
+
 ifeq ($(BR2_PACKAGE_XLIB_LIBXI),y)
 WINE_CONF_OPTS += --with-xinput --with-xinput2
 WINE_DEPENDENCIES += xlib_libXi