icu: fix build after custom data library patch
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 29 Jul 2014 11:23:34 +0000 (13:23 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 29 Jul 2014 11:23:34 +0000 (13:23 +0200)
Commit abded6bfead49d61c24a45d811a83ca082adf677 ("icu: add an option
to add a custom data library file") broke the build because of an
improper test on a non-qstripped variable. This commit fixes that.

Fixes:

  http://autobuild.buildroot.org/results/02a/02a0800b01a4bf8734d601f79dc12663fe8f7542/
  and many other similar occurences of the same issue.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/icu/icu.mk

index 208229d7131d4638d89bb1a8d06301bcd07c69ac..0312fac0a1b1ca002720ad53cd531ace2dbc8ea5 100644 (file)
@@ -26,9 +26,11 @@ ICU_MAKE = $(MAKE1)
 ICU_SUBDIR = source
 HOST_ICU_SUBDIR = source
 
-ifneq ($(BR2_PACKAGE_ICU_CUSTOM_DATA_PATH),)
+ICU_CUSTOM_DATA_PATH = $(call qstrip,$(BR2_PACKAGE_ICU_CUSTOM_DATA_PATH))
+
+ifneq ($(ICU_CUSTOM_DATA_PATH),)
 define ICU_COPY_CUSTOM_DATA
-       cp $(BR2_PACKAGE_ICU_CUSTOM_DATA_PATH) $(@D)/source/data/in/
+       cp $(ICU_CUSTOM_DATA_PATH) $(@D)/source/data/in/
 endef
 ICU_POST_PATCH_HOOKS += ICU_COPY_CUSTOM_DATA
 endif