sdl_mixer: fix sdl dependency
authorPeter Korsgaard <jacmet@sunsite.dk>
Thu, 17 Jul 2008 09:55:27 +0000 (09:55 -0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Thu, 17 Jul 2008 09:55:27 +0000 (09:55 -0000)
package/sdl_mixer/Config.in
package/sdl_mixer/sdl_mixer.mk

index 2cc1457a703f7a5f0e9e90f106fe3f6dcffe6d13..52247cd4b564b272738d0d1ca601f838e6bcf0a3 100644 (file)
@@ -1,8 +1,8 @@
 config BR2_PACKAGE_SDL_MIXER
        bool "SDL_mixer"
        default n
+       depends on BR2_PACKAGE_SDL
        help
-
          SDL_mixer is a sample multi-channel audio mixer library.
          It supports any number of simultaneously playing channels of
          16 bit stereo audio, plus a single channel of music, mixed
index f6a8d4394bcadfd393aed70e19adf60210c912ae..3c88eae263533d8693bf760e4c4a47d4bb6fd548 100644 (file)
@@ -48,7 +48,7 @@ $(TARGET_DIR)/usr/lib/libSDL_mixer.so: $(STAGING_DIR)/usr/lib/libSDL_mixer.so
        cp -dpf $(STAGING_DIR)/usr/lib/libSDL_mixer*.so* $(TARGET_DIR)/usr/lib/
        -$(STRIPCMD) $(STRIP_STRIP_UNNEEDED) $(TARGET_DIR)/usr/lib/libSDL_mixer*.so*
 
-sdl_mixer: uclibc $(TARGET_DIR)/usr/lib/libSDL_mixer.so
+sdl_mixer: sdl uclibc $(TARGET_DIR)/usr/lib/libSDL_mixer.so
 
 sdl_mixer-clean:
        rm -f $(TARGET_DIR)/usr/lib/libSDL_mixer*.so*