package/qjson: remove qt4 support
authorPeter Korsgaard <peter@korsgaard.com>
Wed, 6 Feb 2019 14:10:55 +0000 (15:10 +0100)
committerArnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Wed, 6 Feb 2019 14:43:47 +0000 (15:43 +0100)
Qt4 support is about to be dropped, so remove the support from qjson as
well.

Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
[Arnout: also remove redundant BR2_STATIC_LIBS dependency/comment]
Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
package/qjson/Config.in
package/qjson/qjson.mk

index 5c423bf317f6714ef2815574524ec363700ce5e0..adb06cddc0d96d34efb565296f075ebfff3de891 100644 (file)
@@ -1,13 +1,8 @@
 config BR2_PACKAGE_QJSON
        bool "qjson"
-       depends on !BR2_STATIC_LIBS
-       depends on BR2_PACKAGE_QT || BR2_PACKAGE_QT5
+       depends on BR2_PACKAGE_QT5
        help
          QJson is a Qt-based library that maps JSON data to
          QVariant objects and vice versa.
 
          http://qjson.sourceforge.net
-
-comment "qjson needs a toolchain w/ dynamic library"
-       depends on BR2_STATIC_LIBS
-       depends on !BR2_PACKAGE_QT && !BR2_PACKAGE_QT5
index 1777b9454cf42b8934ebcb3c0657cb64037f360f..718d6622a8bc594e70cd8e28fa9ab9b26f4a08af 100644 (file)
@@ -7,9 +7,7 @@
 QJSON_VERSION = 0.9.0
 QJSON_SITE = $(call github,flavio,qjson,$(QJSON_VERSION))
 QJSON_INSTALL_STAGING = YES
-QJSON_DEPENDENCIES = \
-       $(if $(BR2_PACKAGE_QT),qt) \
-       $(if $(BR2_PACKAGE_QT5),qt5base)
+QJSON_DEPENDENCIES = qt5base
 QJSON_LICENSE = LGPL-2.1
 QJSON_LICENSE_FILES = COPYING.lib