package/libudfread: new package
authorBernd Kuhls <bernd.kuhls@t-online.de>
Sun, 5 Apr 2020 18:20:34 +0000 (20:20 +0200)
committerYann E. MORIN <yann.morin.1998@free.fr>
Mon, 6 Apr 2020 20:03:10 +0000 (22:03 +0200)
Upcoming release of kodi 19.0 will add libudfread as optional
dependency: https://github.com/xbmc/xbmc/pull/17612

Please note that the removed support of libudf was added on the master
branch so we do not need to backport udf support to kodi 18.x:
https://github.com/xbmc/xbmc/commit/558b54a79eff717237919afe453ec09e0851d3a5

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
[yann.morin.1998@free.fr: two spaces in hash files]
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
DEVELOPERS
package/Config.in
package/libudfread/Config.in [new file with mode: 0644]
package/libudfread/libudfread.hash [new file with mode: 0644]
package/libudfread/libudfread.mk [new file with mode: 0644]

index e9ac2b746086be7201ef7317cc7d7366baa8b3d6..bf209b45d648234a0db3ab835b6d29564fadeeb8 100644 (file)
@@ -396,6 +396,7 @@ F:  package/libsndfile/
 F:     package/libsoil/
 F:     package/libsoundtouch/
 F:     package/libsquish/
+F:     package/libudfread/
 F:     package/liburiparser/
 F:     package/libva/
 F:     package/libva-intel-driver/
index 373868ca823658f3d4ce01625eeb92eef50d2581..fce3eeff03148a31638d587376af7c2bad03076c 100644 (file)
@@ -1619,6 +1619,7 @@ menu "Multimedia"
        source "package/libopenh264/Config.in"
        source "package/libopusenc/Config.in"
        source "package/libtheora/Config.in"
+       source "package/libudfread/Config.in"
        source "package/libvpx/Config.in"
        source "package/libyuv/Config.in"
        source "package/live555/Config.in"
diff --git a/package/libudfread/Config.in b/package/libudfread/Config.in
new file mode 100644 (file)
index 0000000..8d42570
--- /dev/null
@@ -0,0 +1,6 @@
+config BR2_PACKAGE_LIBUDFREAD
+       bool "libudfread"
+       help
+         UDF reader
+
+         https://code.videolan.org/videolan/libudfread
diff --git a/package/libudfread/libudfread.hash b/package/libudfread/libudfread.hash
new file mode 100644 (file)
index 0000000..9a68f62
--- /dev/null
@@ -0,0 +1,3 @@
+# Locally computed
+sha256  c4c5ee6b65be051fb1f2a738f726f2afc8601620e8f013d087769dc13aab6d4c  libudfread-1.0.0.tar.bz2
+sha256  dc626520dcd53a22f727af3ee42c770e56c97a64fe3adb063799d8ab032fe551  COPYING
diff --git a/package/libudfread/libudfread.mk b/package/libudfread/libudfread.mk
new file mode 100644 (file)
index 0000000..53ee4a5
--- /dev/null
@@ -0,0 +1,15 @@
+################################################################################
+#
+# libudfread
+#
+################################################################################
+
+LIBUDFREAD_VERSION = 1.0.0
+LIBUDFREAD_SOURCE = libudfread-$(LIBUDFREAD_VERSION).tar.bz2
+LIBUDFREAD_SITE = https://code.videolan.org/videolan/libudfread/-/archive/$(LIBUDFREAD_VERSION)
+LIBUDFREAD_AUTORECONF = YES
+LIBUDFREAD_INSTALL_STAGING = YES
+LIBUDFREAD_LICENSE = LGPL-2.1+
+LIBUDFREAD_LICENSE_FILES = COPYING
+
+$(eval $(autotools-package))