busybox: get rid of BR2_PACKAGE_BUSYBOX_FULLINSTALL
authorPeter Korsgaard <jacmet@sunsite.dk>
Tue, 21 Dec 2010 19:25:29 +0000 (20:25 +0100)
committerPeter Korsgaard <jacmet@sunsite.dk>
Tue, 21 Dec 2010 19:25:29 +0000 (20:25 +0100)
As discussed on IRC, this only needs to be disabled for very specific
configurations, and it can nowadays be done with a custom busybox
.config (CONFIG_INSTALL_APPLET_DONT), so get rid of the option.

Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/busybox/Config.in
package/busybox/busybox.mk

index 19c68cda5475b863d53d479ca31a88f2ca3b520a..79a6341606a31ac0c4969c9c5e23359ec080f16f 100644 (file)
@@ -42,18 +42,6 @@ config BR2_BUSYBOX_VERSION
        default "1.17.4"        if BR2_BUSYBOX_VERSION_1_17_X
        default "1.18.1"        if BR2_BUSYBOX_VERSION_1_18_X
 
-config BR2_PACKAGE_BUSYBOX_FULLINSTALL
-       bool "Install symlinks to BusyBox applets"
-       default y
-       help
-         If you want to run BusyBox's own full install for the
-         configured applets, then answer Y.
-
-         This may overwrite files from other packages if your
-         busybox includes replacement applets for the package.
-
-         If you wish to just install /bin/busybox, then answer N.
-
 config BR2_PACKAGE_BUSYBOX_CONFIG
        string "BusyBox configuration file to use?"
        default "package/busybox/busybox-1.18.x.config" if BR2_PACKAGE_BUSYBOX_SNAPSHOT
index 1010df38d27b4277e0f831b3677550093b8034f1..8bff1a68c6607190064e4b7f5e664b61e683a2fa 100644 (file)
@@ -126,21 +126,11 @@ define BUSYBOX_BUILD_CMDS
                CROSS_COMPILE="$(TARGET_CROSS)" -C $(@D)
 endef
 
-ifeq ($(BR2_PACKAGE_BUSYBOX_FULLINSTALL),y)
-define BUSYBOX_INSTALL_BINARY
+define BUSYBOX_INSTALL_TARGET_CMDS
        $(BUSYBOX_MAKE_ENV) $(MAKE) CC="$(TARGET_CC)" ARCH=$(KERNEL_ARCH) \
                PREFIX="$(TARGET_DIR)" EXTRA_LDFLAGS="$(TARGET_LDFLAGS)" \
                CROSS_COMPILE="$(TARGET_CROSS)" CONFIG_PREFIX="$(TARGET_DIR)" \
                -C $(@D) install
-endef
-else
-define BUSYBOX_INSTALL_BINARY
-       install -D -m 0755 $(BUSYBOX_DIR)/busybox $(TARGET_DIR)/bin/busybox
-endef
-endif
-
-define BUSYBOX_INSTALL_TARGET_CMDS
-       $(BUSYBOX_INSTALL_BINARY)
        if [ ! -f $(TARGET_DIR)/usr/share/udhcpc/default.script ]; then \
                $(INSTALL) -m 0755 -D package/busybox/udhcpc.script \
                        $(TARGET_DIR)/usr/share/udhcpc/default.script; \