Makefile: update help text
authorPeter Korsgaard <jacmet@sunsite.dk>
Sun, 4 Oct 2009 19:42:54 +0000 (21:42 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Sun, 4 Oct 2009 19:45:10 +0000 (21:45 +0200)
get rid of the removed saveconfig/getconfig targets, and instead document
randconfig/defconfig/allyesconfig/allnoconfig.

Furthermore, get rid of the unused tags target.

Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Makefile

index 7fe30a7bea365cc49354ada70685767e6dc5b177..a14c62d28e9f0c93f8be2bc61c80ec0a6b013496 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -29,7 +29,7 @@ CONFIG=package/config
 DATE:=$(shell date +%Y%m%d)
 
 noconfig_targets:=menuconfig xconfig config oldconfig randconfig \
-       defconfig allyesconfig allnoconfig release tags \
+       defconfig allyesconfig allnoconfig release \
        source-check help
 
 # Strip quotes and then whitespaces
@@ -528,7 +528,6 @@ allyesconfig: $(CONFIG)/conf
        @KCONFIG_AUTOCONFIG=$(CONFIG)/buildroot-config/auto.conf \
                KCONFIG_AUTOHEADER=$(CONFIG)/buildroot-config/autoconf.h \
                $(CONFIG)/conf -y $(CONFIG_CONFIG_IN)
-       #sed -i -e "s/^CONFIG_DEBUG.*/# CONFIG_DEBUG is not set/" .config
 
 allnoconfig: $(CONFIG)/conf
        @mkdir -p $(CONFIG)/buildroot-config
@@ -584,11 +583,13 @@ help:
        @echo
        @echo 'Configuration:'
        @echo '  menuconfig             - interactive curses-based configurator'
-       @echo '  xconfig                - interactive Qt-based configurator'
+       @echo '  xconfig                - interactive Qt-based configurator'
        @echo '  oldconfig              - resolve any unresolved symbols in .config'
+       @echo '  randconfig             - New config with random answer to all options'
+       @echo '  defconfig              - New config with default answer to all options'
+       @echo '  allyesconfig           - New config where all options are accepted with yes'
+       @echo '  allnoconfig            - New config where all options are answered with no'
        @echo '  configured             - make {uclibc/busybox/linux26}-config'
-       @echo '  saveconfig             - save current configuration under local/<project>'
-       @echo '  getconfig              - restore saved configuration from local/<project>'
        @echo
        @echo 'Miscellaneous:'
        @echo '  source                 - download all sources needed for offline-build'
@@ -606,5 +607,5 @@ release: distclean
        rm -rf $$OUT
 
 .PHONY: dummy subdirs release distclean clean config oldconfig \
-       menuconfig xconfig tags check test depend defconfig help
+       menuconfig xconfig check test depend defconfig help