-From 57383dc900e76e65ce5e5dc95f776e086100344d Mon Sep 17 00:00:00 2001
+From 3656db7fd23d166238cb8816c0d097095911b3fc Mon Sep 17 00:00:00 2001
From: Peter Seiderer <ps.report@gmx.net>
Date: Sat, 12 Jan 2019 10:22:38 +0100
Subject: [PATCH] meson.build: enable CPP include check only in case CPP
header inclusion test, build the test only in case C++/CPP compiler
is available.
+Upstream: https://gitlab.freedesktop.org/libinput/libinput/commit/4516ba977c1e22d01da4cc50a8ebffa5d11d73f1
+
+Signed-off-by: Peter Seiderer <ps.report@gmx.net>
+[Rebased on 1.12.6, add upstream link]
Signed-off-by: Peter Seiderer <ps.report@gmx.net>
+---
---
meson.build | 16 +++++++++-------
1 file changed, 9 insertions(+), 7 deletions(-)
diff --git a/meson.build b/meson.build
-index a9c7c185..8183822e 100644
+index 8127c674..86960d84 100644
--- a/meson.build
+++ b/meson.build
@@ -1,4 +1,4 @@
-project('libinput', 'c', 'cpp',
+project('libinput', 'c',
- version : '1.12.5',
+ version : '1.12.6',
license : 'MIT/Expat',
default_options : [ 'c_std=gnu99', 'warning_level=2' ],
-@@ -641,12 +641,14 @@ executable('test-build-linker',
+@@ -642,12 +642,14 @@ executable('test-build-linker',
include_directories : [includes_src, includes_include],
dependencies : [ dep_libinput, dep_libinput_util ],
install : false)
-# From https://lists.freedesktop.org/archives/wayland-devel/2019-January/039804.html
-md5 40dcc044443c9314537f605b6f30bf17 libinput-1.12.5.tar.xz
-sha1 7c0b75e8cf2f1747fb8ae69300acabd46f7a7f0d libinput-1.12.5.tar.xz
-sha256 7d4b6831010ef3bf69df4b41170047fa4325edef8ff5d2d28e78281af0687123 libinput-1.12.5.tar.xz
-sha512 9365b91b3ac2c4ff0f9927913242afac7677979682dd7b541001b13d09d7982acd854f6d348101cfa4b0854c6a92b4c683f62593a97870e32ae3d607eaeae3ff libinput-1.12.5.tar.xz
+# From https://lists.freedesktop.org/archives/wayland-devel/2019-January/039864.html
+md5 8cf10cc0fdfab865b105dd28283fa0fd libinput-1.12.6.tar.xz
+sha1 e3044cd2073312c24a315df1be4aa38da6bb2bbd libinput-1.12.6.tar.xz
+sha256 12b4023a3fc683d3d8127db573bdf925a2ef366615042f69c87e57c32a50f45d libinput-1.12.6.tar.xz
+sha512 02ad90c77a0c8c27fd96ec34e1546c5f0947ced49bad386372c1ef7c41b3b2157c39020f0766f20aaf2ab3c97128567e169279bea21115ced39499dda325d2ef libinput-1.12.6.tar.xz
# License files
sha256 70d5b1dfe5a9c50a1f2ea91b1c2b1c85d876c5c92339585edbb85cf69e945e14 COPYING
#
################################################################################
-LIBINPUT_VERSION = 1.12.5
+LIBINPUT_VERSION = 1.12.6
LIBINPUT_SOURCE = libinput-$(LIBINPUT_VERSION).tar.xz
LIBINPUT_SITE = http://www.freedesktop.org/software/libinput
LIBINPUT_DEPENDENCIES = host-pkgconf libevdev mtdev udev