sparc64: fix toolchain building when C++ is enabled
authorWaldemar Brodkorb <wbx@openadk.org>
Sun, 11 Oct 2015 17:17:27 +0000 (19:17 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 12 Oct 2015 21:45:01 +0000 (23:45 +0200)
Disable libsanitizer for sparc64, too. Same problem as for
sparc, see https://bugs.busybox.net/show_bug.cgi?id=7951

Reported-By: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Waldemar Brodkorb <wbx@openadk.org>
Reviewed-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/gcc/gcc.mk

index 4def65c94606783f1c9e22eed4473a44cfddc38c..1b30e6d69ec6ff028bbe092044888ee82df3ed1a 100644 (file)
@@ -142,7 +142,7 @@ endif
 
 # libsanitizer is broken for SPARC
 # https://bugs.busybox.net/show_bug.cgi?id=7951
-ifeq ($(BR2_sparc),y)
+ifeq ($(BR2_sparc)$(BR2_sparc64),y)
 HOST_GCC_COMMON_CONF_OPTS += --disable-libsanitizer
 endif