gpsd: remove option to enable latency measurement capabilities
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 24 Jul 2012 20:18:18 +0000 (22:18 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 24 Jul 2012 20:18:18 +0000 (22:18 +0200)
It currently fails to build with:

libgpsd_core.c: In function 'gpsd_poll':
libgpsd_core.c:881: error: 'const struct gps_type_t' has no member named 'min_cycle'
libgpsd_core.c:884: error: 'const struct gps_type_t' has no member named 'min_cycle'

and is probably not a very important feature for normal users of gpsd.

The build problem has been reported to the gpsd-users mailing list.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/gpsd/Config.in
package/gpsd/gpsd.mk

index db6bec2d75ccb2039d4ad8dff3bf0ab93ba90ca1..8643492fb8daa77756a2b52a99922fb41b001e54 100644 (file)
@@ -20,9 +20,6 @@ config BR2_PACKAGE_GPSD_DEVICES
 menu "Features"
        depends on BR2_PACKAGE_GPSD
 
-config BR2_PACKAGE_GPSD_TIMING
-       bool "latency timing support"
-
 config BR2_PACKAGE_GPSD_CLIENT_DEBUG
        bool "client debugging support"
 
index 7d1dbcdac474e12534f985d0446d10770286789a..c5270bd2ba70544fb3166a9dc0f78a6b1d8a1e8e 100644 (file)
@@ -176,9 +176,6 @@ endif
 ifeq ($(BR2_PACKAGE_GPSD_PROFILING),y)
        GPSD_SCONS_OPTS += profiling=yes
 endif
-ifeq ($(BR2_PACKAGE_GPSD_TIMING),y)
-       GPSD_SCONS_OPTS += timing=yes
-endif
 ifneq ($(BR2_PACKAGE_GPSD_CLIENT_DEBUG),y)
        GPSD_SCONS_OPTS += clientdebug=no
 endif