package/erlang: needs threads
authorBernd Kuhls <bernd.kuhls@t-online.de>
Sat, 21 Jul 2018 09:13:38 +0000 (11:13 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sat, 21 Jul 2018 20:54:27 +0000 (22:54 +0200)
Due to the removal of the non-smp option threads are needed now:
https://github.com/erlang/otp/commit/ee297c32a768ec333e2a8a3ef829a7690e91d306#diff-900a5d0495caac38a1f51a2cae1b2594R974

Fixes
http://autobuild.buildroot.net/results/285/285ef07d8e0614dd90a1e4dd3ee28b116990dc0f/

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/erlang/Config.in
package/erlang/erlang.mk

index bf745555e855d6a688b4df0ec8f23390515bf2af..75ba17086a59cd18cc4b65875fb237a73e2d47d7 100644 (file)
@@ -12,15 +12,16 @@ config BR2_PACKAGE_ERLANG_ARCH_SUPPORTS
        # erlang needs host-erlang
        depends on BR2_PACKAGE_HOST_ERLANG_ARCH_SUPPORTS
 
-comment "erlang needs a toolchain w/ dynamic library"
+comment "erlang needs a toolchain w/ dynamic library, threads"
        depends on BR2_USE_MMU # fork()
        depends on BR2_PACKAGE_ERLANG_ARCH_SUPPORTS
-       depends on BR2_STATIC_LIBS
+       depends on BR2_STATIC_LIBS || !BR2_TOOLCHAIN_HAS_THREADS
 
 config BR2_PACKAGE_ERLANG
        bool "erlang"
        depends on BR2_USE_MMU # fork()
        depends on !BR2_STATIC_LIBS
+       depends on BR2_TOOLCHAIN_HAS_THREADS
        depends on BR2_PACKAGE_ERLANG_ARCH_SUPPORTS
        help
          Erlang is a programming language used to build massively
index 786641e4bd6e18bcb9e9d464f38c330e9e1efeff..2ac903ffeae7a8e28a57eac71892df4974f0147b 100644 (file)
@@ -43,10 +43,6 @@ HOST_ERLANG_CONF_OPTS = --without-javac --with-ssl=$(HOST_DIR)
 
 HOST_ERLANG_CONF_OPTS += --without-termcap
 
-ifeq ($(BR2_TOOLCHAIN_HAS_THREADS),)
-ERLANG_CONF_OPTS += --disable-threads
-endif
-
 ifeq ($(BR2_PACKAGE_NCURSES),y)
 ERLANG_CONF_OPTS += --with-termcap
 ERLANG_DEPENDENCIES += ncurses
@@ -61,8 +57,7 @@ else
 ERLANG_CONF_OPTS += --without-ssl
 endif
 
-# ODBC support in erlang requires threads
-ifeq ($(BR2_PACKAGE_UNIXODBC)$(BR2_TOOLCHAIN_HAS_THREADS),yy)
+ifeq ($(BR2_PACKAGE_UNIXODBC),y)
 ERLANG_DEPENDENCIES += unixodbc
 ERLANG_CONF_OPTS += --with-odbc
 else