package/json-glib: enable gobject-introspection support
authorAdam Duskett <Aduskett@gmail.com>
Wed, 1 Apr 2020 00:21:27 +0000 (17:21 -0700)
committerYann E. MORIN <yann.morin.1998@free.fr>
Mon, 6 Apr 2020 20:35:22 +0000 (22:35 +0200)
If gobject-introspection is selected, add the gobject-introspection package to
the dependency list and set the conf opt -Dintrospection=true.

Signed-off-by: Adam Duskett <Aduskett@gmail.com>
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
package/json-glib/json-glib.mk

index 7405b28b2e905d37cce7944e6b0be1be97429797..accdb4f888a65c783a6e1ed227eba0cdb3865fd2 100644 (file)
@@ -17,7 +17,12 @@ JSON_GLIB_DEPENDENCIES = \
        host-pkgconf \
        libglib2
 
-JSON_GLIB_CONF_OPTS = -Dintrospection=false
+ifeq ($(BR2_PACKAGE_GOBJECT_INTROSPECTION),y)
+JSON_GLIB_CONF_OPTS += -Dintrospection=true
+JSON_GLIB_DEPENDENCIES += gobject-introspection
+else
+JSON_GLIB_CONF_OPTS += -Dintrospection=false
+endif
 
 JSON_GLIB_LDFLAGS = $(TARGET_LDFLAGS) $(TARGET_NLS_LIBS)