package/skeleton-init-openrc: fix root filesystem ro/rw remount
authorCarlos Santos <unixmania@gmail.com>
Mon, 24 Feb 2020 11:41:34 +0000 (08:41 -0300)
committerYann E. MORIN <yann.morin.1998@free.fr>
Mon, 24 Feb 2020 17:37:32 +0000 (18:37 +0100)
The regular expressions used in the sed commands assumes that there is a
space after '/dev/root' but the skeleton file contains a tab. Use a more
flexible '[[:blank:]]', instead.

Signed-off-by: Carlos Santos <unixmania@gmail.com>
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
package/skeleton-init-openrc/skeleton-init-openrc.mk

index 656fc531d7ad0ad6769d1b4c5b7af5d826cdf1be..b0538ad03ff6203cbe24ebc2e2e4bd2a5af4bed9 100644 (file)
@@ -19,13 +19,13 @@ ifeq ($(BR2_TARGET_GENERIC_REMOUNT_ROOTFS_RW),y)
 # Comment /dev/root entry in fstab. When openrc does not find fstab entry for
 # "/", it will try to remount "/" as "rw".
 define SKELETON_INIT_OPENRC_ROOT_RO_OR_RW
-       $(SED) '\:^/dev/root :s/^/# /' $(TARGET_DIR)/etc/fstab
+       $(SED) '\:^/dev/root[[:blank:]]:s/^/# /' $(TARGET_DIR)/etc/fstab
 endef
 else
 # Uncomment /dev/root entry in fstab which has "ro" option so openrc notices
 # it and doesn't remount root to rw.
 define SKELETON_INIT_OPENRC_ROOT_RO_OR_RW
-       $(SED) '\:^# /dev/root:s/^# //' $(TARGET_DIR)/etc/fstab
+       $(SED) '\:^#[[:blank:]]*/dev/root[[:blank:]]:s/^# //' $(TARGET_DIR)/etc/fstab
 endef
 endif # BR2_TARGET_GENERIC_REMOUNT_ROOTFS_RW