stunnel: install configuration file unconditionally
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 30 Nov 2014 14:18:48 +0000 (15:18 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Mon, 1 Dec 2014 23:27:15 +0000 (00:27 +0100)
As discussed, users should use a rootfs overlay or a post-build script
instead of a custom skeleton to override files installed by Buildroot,
so there is no point in having conditions when installing init scripts
or configuration files.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Acked-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/stunnel/stunnel.mk

index ac2963e03d28947332f7b5d81d553e3b6c8ce6eb..3d0596d2723ee00b7399ef723156e9a5cf9d4429 100644 (file)
@@ -19,9 +19,8 @@ STUNNEL_CONF_OPTS += --disable-systemd
 endif
 
 define STUNNEL_INSTALL_CONF
-       [ -f $(TARGET_DIR)/etc/stunnel/stunnel.conf ] || \
-               $(INSTALL) -m 0644 -D $(@D)/tools/stunnel.conf \
-                       $(TARGET_DIR)/etc/stunnel/stunnel.conf
+       $(INSTALL) -m 0644 -D $(@D)/tools/stunnel.conf \
+               $(TARGET_DIR)/etc/stunnel/stunnel.conf
        rm -f $(TARGET_DIR)/etc/stunnel/stunnel.conf-sample
 endef