package/mplayer: adjust configure options to updated libdvdread/libdvdnav
authorBernd Kuhls <bernd.kuhls@t-online.de>
Sun, 19 Jun 2016 16:20:27 +0000 (18:20 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Sun, 19 Jun 2016 21:01:42 +0000 (23:01 +0200)
Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/mplayer/mplayer.mk

index 9ae7ca4e0c55d78128f1ad4cb8ab8f0e94296592..541dd4f75cbb660f07a8b26a2411b3ba052d37a6 100644 (file)
@@ -123,7 +123,7 @@ MPLAYER_CONF_OPTS += --disable-libcdio
 # autodetection find which library to link with.
 ifeq ($(BR2_PACKAGE_LIBDVDREAD),y)
 MPLAYER_CONF_OPTS +=  \
-       --with-dvdread-config=$(STAGING_DIR)/usr/bin/dvdread-config
+       --with-dvdread-config="$(PKG_CONFIG_HOST_BINARY) dvdread"
 MPLAYER_DEPENDENCIES += libdvdread
 endif
 
@@ -131,7 +131,7 @@ endif
 # find which library to link with.
 ifeq ($(BR2_PACKAGE_LIBDVDNAV),y)
 MPLAYER_CONF_OPTS +=  \
-       --with-dvdnav-config=$(STAGING_DIR)/usr/bin/dvdnav-config
+       --with-dvdnav-config="$(PKG_CONFIG_HOST_BINARY) dvdnav"
 MPLAYER_DEPENDENCIES += libdvdnav
 endif