php: add FPM support
authorJordi Llonch <jordi.llonch@rochsystems.com>
Tue, 15 Jul 2014 18:07:42 +0000 (18:07 +0000)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 15 Jul 2014 19:10:55 +0000 (21:10 +0200)
[Thomas: adjust commit title, as suggested by Gustavo.]

Signed-off-by: Jordi Llonch <jordi.llonch@rochsystems.com>
Acked-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/php/Config.in
package/php/php.mk

index 46444a56007921b507dd7374cf6a1c43a864b387..4ee14c320a3b82f69eb7826809a981e044faa2b8 100644 (file)
@@ -17,6 +17,9 @@ config BR2_PACKAGE_PHP_CLI
 config BR2_PACKAGE_PHP_CGI
        bool
 
+config BR2_PACKAGE_PHP_FPM
+        bool
+
 choice
        prompt "Interface"
        default BR2_PACKAGE_PHP_SAPI_CGI
@@ -37,6 +40,13 @@ config BR2_PACKAGE_PHP_SAPI_CLI
        help
          Command Line Interface
 
+config BR2_PACKAGE_PHP_SAPI_FPM
+       bool "FPM"
+       depends on BR2_USE_MMU
+       select BR2_PACKAGE_PHP_FPM
+       help
+         PHP-FPM (FastCGI Process Manager)
+
 config BR2_PACKAGE_PHP_SAPI_CLI_CGI
        bool "CGI and CLI"
        # CGI uses fork()
@@ -46,6 +56,14 @@ config BR2_PACKAGE_PHP_SAPI_CLI_CGI
        help
          Command line and Common gateway interfaces
 
+config BR2_PACKAGE_PHP_SAPI_CLI_FPM
+       bool "FPM and CLI"
+       depends on BR2_USE_MMU
+       select BR2_PACKAGE_PHP_CLI
+       select BR2_PACKAGE_PHP_FPM
+       help
+         Command line and PHP-FPM (FastCGI Process Manager)
+
 endchoice
 
 endif
index 4d3aa7d18d35da7d226acb7721a03b8a1875e9ae..fea03ebb3aec904a5170fdf6c89700ef90619615 100644 (file)
@@ -47,6 +47,7 @@ endif
 
 PHP_CONF_OPT += $(if $(BR2_PACKAGE_PHP_CLI),,--disable-cli)
 PHP_CONF_OPT += $(if $(BR2_PACKAGE_PHP_CGI),,--disable-cgi)
+PHP_CONF_OPT += $(if $(BR2_PACKAGE_PHP_FPM),--enable-fpm,--disable-fpm)
 
 ### Extensions
 PHP_CONF_OPT += $(if $(BR2_PACKAGE_PHP_EXT_SOCKETS),--enable-sockets) \