netplug: disable -Werror to fix build failure
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 10 May 2010 21:39:50 +0000 (23:39 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Tue, 11 May 2010 06:59:02 +0000 (08:59 +0200)
netplug uses nested functions, and gcc generates a warning that
is turned into an error:

cc1: warnings being treated as errors
if_info.c: In function 'ifsm_scriptdone':
if_info.c:289: error: generating trampoline in object (requires executable stack)

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
CHANGES
package/netplug/netplug-1.2.9-disable-werror.patch [new file with mode: 0644]

diff --git a/CHANGES b/CHANGES
index 7dd7a5d261303afcfa4fbac2b743be938b17a130..f305fd1bfabf061a7d4e31ee210d187e291d46d8 100644 (file)
--- a/CHANGES
+++ b/CHANGES
@@ -3,10 +3,11 @@
        Fixes all over the tree.
 
        Updated/fixed packages: busybox, customize, hal, hostapd,
-       less, libxcb, mplayer, pciutils, xdriver_xf86-video-openchrome,
-       usb_modeswitch, usbutils, wpa_supplicant, xapp_bdftopcf,
-       xapp_mkfontdir, xfont_encodings, xlib_libX11, xlib_libXfont,
-       xlib_xtrans, xproto_fontcacheproto, xproto_fontsproto, xvkbd
+       less, libxcb, mplayer, netplug, pciutils,
+       xdriver_xf86-video-openchrome, usb_modeswitch, usbutils,
+       wpa_supplicant, xapp_bdftopcf, xapp_mkfontdir,
+       xfont_encodings, xlib_libX11, xlib_libXfont, xlib_xtrans,
+       xproto_fontcacheproto, xproto_fontsproto, xvkbd
 
        Removed packages: vice
 
diff --git a/package/netplug/netplug-1.2.9-disable-werror.patch b/package/netplug/netplug-1.2.9-disable-werror.patch
new file mode 100644 (file)
index 0000000..d8a3e15
--- /dev/null
@@ -0,0 +1,22 @@
+netplug uses nested functions, and gcc generates a warning that
+is turned into an error:
+
+cc1: warnings being treated as errors
+if_info.c: In function 'ifsm_scriptdone':
+if_info.c:289: error: generating trampoline in object (requires executable stack)
+
+Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
+
+Index: netplug-1.2.9/Makefile
+===================================================================
+--- netplug-1.2.9.orig/Makefile        2010-05-09 21:07:40.000000000 +0200
++++ netplug-1.2.9/Makefile     2010-05-09 21:09:32.000000000 +0200
+@@ -9,7 +9,7 @@
+ install_opts :=
+-CFLAGS += -Wall -Werror -std=gnu99 -DNP_ETC_DIR='"$(etcdir)"' \
++CFLAGS += -Wall -std=gnu99 -DNP_ETC_DIR='"$(etcdir)"' \
+       -DNP_SCRIPT_DIR='"$(scriptdir)"' -ggdb3 -O3 -DNP_VERSION='"$(version)"'
+ netplugd: config.o netlink.o lib.o if_info.o main.o