Initial support for MS7206SE01 sh2a board.
authorPaul Mundt <lethal@linux-sh.org>
Tue, 3 May 2005 13:56:36 +0000 (13:56 -0000)
committerPaul Mundt <lethal@linux-sh.org>
Tue, 3 May 2005 13:56:36 +0000 (13:56 -0000)
Config.in
target/device/Config.in
target/device/Hitachi/Config.in [new file with mode: 0644]
target/device/Hitachi/MS7206SE01/Makefile.in [new file with mode: 0644]
target/device/Hitachi/MS7206SE01/uClibc.config.sh2a_nofpueb [new file with mode: 0644]
target/device/Hitachi/Makefile.in [new file with mode: 0644]

index eddf84d470d59592d2d19c0184cfd14505c8aab7..522106e2e1df7bcfb1da2440af9d19aa66c91d99 100644 (file)
--- a/Config.in
+++ b/Config.in
@@ -36,6 +36,28 @@ config BR2_mipsel
 config BR2_powerpc
        bool "powerpc"
 
+config BR2_sh
+       bool "sh"
+
+config BR2_sparc
+       bool "sparc"
+
+endchoice
+
+#
+# Keep the variants seperate, there's no need to clutter everything else.
+# sh is fairly "special" in this regard, as virtually everyone else has
+# things kept down to a _sensible_ number of target variants. No such
+# luck for sh..
+#
+choice
+       prompt "Target Architecture Variant"
+       depends BR2_sh
+       default BR2_sh4
+
+config BR2_sh2a_nofpueb
+       bool "sh2a_nofpueb"
+
 config BR2_sh3
        bool "sh3"
 
@@ -48,27 +70,24 @@ config BR2_sh4
 config BR2_sh4eb
        bool "sh4eb"
 
-config BR2_sparc
-       bool "sparc"
-
 endchoice
 
 config BR2_ARCH
        string
-       default "arm"     if BR2_arm
-       default "armeb"   if BR2_armeb
-       default "cris"    if BR2_cris
-       default "i386"    if BR2_i386
-       default "m68k"    if BR2_m68k
-       default "mips"    if BR2_mips
-       default "mipsel"  if BR2_mipsel
-       default "powerpc" if BR2_powerpc
-       default "sh3"     if BR2_sh3
-       default "sh3eb"   if BR2_sh3eb
-       default "sh4"     if BR2_sh4
-       default "sh4eb"   if BR2_sh4eb
-       default "sparc"   if BR2_sparc
-
+       default "arm"           if BR2_arm
+       default "armeb"         if BR2_armeb
+       default "cris"          if BR2_cris
+       default "i386"          if BR2_i386
+       default "m68k"          if BR2_m68k
+       default "mips"          if BR2_mips
+       default "mipsel"        if BR2_mipsel
+       default "powerpc"       if BR2_powerpc
+       default "sh2a_nofpueb"  if BR2_sh2a_nofpueb
+       default "sh3"           if BR2_sh3
+       default "sh3eb"         if BR2_sh3eb
+       default "sh4"           if BR2_sh4
+       default "sh4eb"         if BR2_sh4eb
+       default "sparc"         if BR2_sparc
 
 menu "Build options"
 
index 3eeb1e3f6eff2a9cd6b33ac257d5e6d58844df3f..30cb7227b68416b24a63d52e873d762e6ece6fdf 100644 (file)
@@ -1,6 +1,7 @@
 menu "Board Support Options"
 
 source "target/device/Soekris/Config.in"
+source "target/device/Hitachi/Config.in"
 source "target/device/AMD/Config.in"
 
 # This must be last
diff --git a/target/device/Hitachi/Config.in b/target/device/Hitachi/Config.in
new file mode 100644 (file)
index 0000000..8048e85
--- /dev/null
@@ -0,0 +1,12 @@
+comment "Hitachi ULSI Systems device support"
+       depends BR2_sh
+
+config BR2_TARGET_HITACHI_SE
+       bool "Board support for Solution Engine development boards"
+       depends on BR2_sh
+       default n
+
+config BR2_TARGET_HITACHI_MS7206SE01
+       bool "MS7206SE01 development board support"
+       depends BR2_TARGET_HITACHI_SE && BR2_sh2a_nofpueb
+       default n
diff --git a/target/device/Hitachi/MS7206SE01/Makefile.in b/target/device/Hitachi/MS7206SE01/Makefile.in
new file mode 100644 (file)
index 0000000..d0f29ca
--- /dev/null
@@ -0,0 +1 @@
+UCLIBC_CONFIG_FILE:=target/device/Hitachi/MS7206SE01/uClibc.config.sh2a_nofpueb
diff --git a/target/device/Hitachi/MS7206SE01/uClibc.config.sh2a_nofpueb b/target/device/Hitachi/MS7206SE01/uClibc.config.sh2a_nofpueb
new file mode 100644 (file)
index 0000000..b302953
--- /dev/null
@@ -0,0 +1,144 @@
+#
+# Automatically generated make config: don't edit
+#
+# TARGET_alpha is not set
+# TARGET_arm is not set
+# TARGET_bfin is not set
+# TARGET_cris is not set
+# TARGET_e1 is not set
+# TARGET_frv is not set
+# TARGET_h8300 is not set
+# TARGET_i386 is not set
+# TARGET_i960 is not set
+# TARGET_m68k is not set
+# TARGET_microblaze is not set
+# TARGET_mips is not set
+# TARGET_nios is not set
+# TARGET_nios2 is not set
+# TARGET_powerpc is not set
+TARGET_sh=y
+# TARGET_sh64 is not set
+# TARGET_sparc is not set
+# TARGET_v850 is not set
+# TARGET_x86_64 is not set
+
+#
+# Target Architecture Features and Options
+#
+HAVE_ELF=y
+ARCH_SUPPORTS_LITTLE_ENDIAN=y
+TARGET_ARCH="sh"
+ARCH_SUPPORTS_BIG_ENDIAN=y
+HAVE_DOT_HIDDEN=y
+CONFIG_SH2A=y
+# CONFIG_SH2 is not set
+# CONFIG_SH3 is not set
+# CONFIG_SH4 is not set
+# ARCH_LITTLE_ENDIAN is not set
+ARCH_BIG_ENDIAN=y
+ARCH_HAS_NO_MMU=y
+# UCLIBC_HAS_FLOATS is not set
+KERNEL_SOURCE="/usr/src/linux"
+UCLIBC_UCLINUX_BROKEN_MUNMAP=y
+EXCLUDE_BRK=y
+C_SYMBOL_PREFIX=""
+HAVE_DOT_CONFIG=y
+
+#
+# General Library Settings
+#
+HAVE_NO_PIC=y
+# HAVE_NO_SHARED is not set
+ARCH_HAS_NO_LDSO=y
+UCLIBC_CTOR_DTOR=y
+# HAS_NO_THREADS is not set
+UCLIBC_HAS_THREADS=y
+# PTHREADS_DEBUG_SUPPORT is not set
+# UCLIBC_HAS_LFS is not set
+# UCLIBC_STATIC_LDCONFIG is not set
+MALLOC=y
+# MALLOC_SIMPLE is not set
+# MALLOC_STANDARD is not set
+MALLOC_GLIBC_COMPAT=y
+UCLIBC_DYNAMIC_ATEXIT=y
+HAS_SHADOW=y
+# UNIX98PTY_ONLY is not set
+ASSUME_DEVPTS=y
+UCLIBC_HAS_TM_EXTENSIONS=y
+UCLIBC_HAS_TZ_CACHING=y
+UCLIBC_HAS_TZ_FILE=y
+UCLIBC_HAS_TZ_FILE_READ_MANY=y
+UCLIBC_TZ_FILE_PATH="/etc/TZ"
+
+#
+# Networking Support
+#
+UCLIBC_HAS_IPV6=y
+UCLIBC_HAS_RPC=y
+UCLIBC_HAS_FULL_RPC=y
+
+#
+# String and Stdio Support
+#
+UCLIBC_HAS_STRING_GENERIC_OPT=y
+UCLIBC_HAS_STRING_ARCH_OPT=y
+UCLIBC_HAS_CTYPE_TABLES=y
+UCLIBC_HAS_CTYPE_SIGNED=y
+# UCLIBC_HAS_CTYPE_UNSAFE is not set
+UCLIBC_HAS_CTYPE_CHECKED=y
+# UCLIBC_HAS_CTYPE_ENFORCED is not set
+UCLIBC_HAS_WCHAR=y
+# UCLIBC_HAS_LOCALE is not set
+UCLIBC_HAS_GLIBC_CUSTOM_PRINTF=y
+UCLIBC_PRINTF_SCANF_POSITIONAL_ARGS=9
+UCLIBC_HAS_SCANF_GLIBC_A_FLAG=y
+# UCLIBC_HAS_STDIO_BUFSIZ_NONE is not set
+# UCLIBC_HAS_STDIO_BUFSIZ_256 is not set
+# UCLIBC_HAS_STDIO_BUFSIZ_512 is not set
+# UCLIBC_HAS_STDIO_BUFSIZ_1024 is not set
+# UCLIBC_HAS_STDIO_BUFSIZ_2048 is not set
+UCLIBC_HAS_STDIO_BUFSIZ_4096=y
+# UCLIBC_HAS_STDIO_BUFSIZ_8192 is not set
+UCLIBC_HAS_STDIO_BUILTIN_BUFFER_NONE=y
+# UCLIBC_HAS_STDIO_BUILTIN_BUFFER_4 is not set
+# UCLIBC_HAS_STDIO_BUILTIN_BUFFER_8 is not set
+UCLIBC_HAS_STDIO_GETC_MACRO=y
+UCLIBC_HAS_STDIO_PUTC_MACRO=y
+UCLIBC_HAS_STDIO_AUTO_RW_TRANSITION=y
+UCLIBC_HAS_FOPEN_EXCLUSIVE_MODE=y
+UCLIBC_HAS_GLIBC_CUSTOM_STREAMS=y
+UCLIBC_HAS_PRINTF_M_SPEC=y
+UCLIBC_HAS_ERRNO_MESSAGES=y
+# UCLIBC_HAS_SYS_ERRLIST is not set
+UCLIBC_HAS_SIGNUM_MESSAGES=y
+# UCLIBC_HAS_SYS_SIGLIST is not set
+UCLIBC_HAS_GNU_GETOPT=y
+
+#
+# Big and Tall
+#
+UCLIBC_HAS_REGEX=y
+# UCLIBC_HAS_WORDEXP is not set
+UCLIBC_HAS_FTW=y
+UCLIBC_HAS_GLOB=y
+
+#
+# Library Installation Options
+#
+RUNTIME_PREFIX="/"
+DEVEL_PREFIX="/usr/"
+
+#
+# uClibc security related options
+#
+# UCLIBC_SECURITY is not set
+
+#
+# uClibc development/debugging options
+#
+CROSS_COMPILER_PREFIX=""
+# DODEBUG is not set
+# DOASSERTS is not set
+# UCLIBC_MALLOC_DEBUGGING is not set
+WARNINGS="-Wall"
+# UCLIBC_MJN3_ONLY is not set
diff --git a/target/device/Hitachi/Makefile.in b/target/device/Hitachi/Makefile.in
new file mode 100644 (file)
index 0000000..e9af5eb
--- /dev/null
@@ -0,0 +1,6 @@
+# Override the default uClibc configuration
+ifeq ($(strip $(BR2_TARGET_HITACHI_MS7206SE01)),y)
+
+include target/device/Hitachi/MS7206SE01/Makefile.in
+
+endif