package/linuxptp adapt to systemctl preset-all
authorJérémy Rosen <jeremy.rosen@smile.fr>
Mon, 16 Dec 2019 10:30:46 +0000 (11:30 +0100)
committerYann E. MORIN <yann.morin.1998@free.fr>
Wed, 18 Dec 2019 17:33:22 +0000 (18:33 +0100)
linuxptp has two services
* linuxptp.service : the actual daemon
* linuxptp-system-clock.service : sync the linux clock to the phc clock

The first was enabled, the second was not, we now enable both

The second has an incorrect (though harmless) WantedBy : there is an
explicit Wants= in linuxptp.service

Signed-off-by: Jérémy Rosen <jeremy.rosen@smile.fr>
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
package/linuxptp/linuxptp-system-clock.service
package/linuxptp/linuxptp.mk

index a4436a34a74bd63bbba0b8bcc7c8ded95c41f877..57beec4579b1c25e91418674345d56ea36669f8f 100644 (file)
@@ -8,4 +8,3 @@ Restart=always
 
 [Install]
 WantedBy=multi-user.target
-WantedBy=linuxptp.service
index c304ff6d6e2dcdcfefff9f59b24730d6b6a173f3..97e4af7be73afd72172d3d72edc0cb24091fd14c 100644 (file)
@@ -42,9 +42,6 @@ define LINUXPTP_INSTALL_INIT_SYSTEMD
                $(TARGET_DIR)/usr/lib/systemd/system/linuxptp.service
        $(INSTALL) -D -m 644 $(LINUXPTP_PKGDIR)/linuxptp-system-clock.service \
                $(TARGET_DIR)/usr/lib/systemd/system/linuxptp-system-clock.service
-       mkdir -p $(TARGET_DIR)/etc/systemd/system/multi-user.target.wants
-       ln -sf ../../../../usr/lib/systemd/system/linuxptp.service \
-               $(TARGET_DIR)/etc/systemd/system/multi-user.target.wants/linuxptp.service
 endef
 
 $(eval $(generic-package))