monit: fix configuration error
authorSimon Dawson <spdawson@gmail.com>
Mon, 11 Jun 2012 22:27:15 +0000 (22:27 +0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Sat, 16 Jun 2012 19:54:10 +0000 (21:54 +0200)
Configuration fails for the monit package, with the following error.

  checking for SSL library directory... Not found

  Couldn't find your SSL library files.
  Use --with-ssl-lib-dir option to fix this problem or disable the
  SSL support with --without-ssl

Tweak the monit configuration command line so that openssl is found.

Signed-off-by: Simon Dawson <spdawson@gmail.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/monit/monit.mk

index 958618dc36d2a6efb9cbac2cca9ee5baa5b6fe69..11bc7e16db30692403307276726d6ff738344bdc 100644 (file)
@@ -15,7 +15,7 @@ MONIT_CONF_OPT += \
        --without-pam
 
 ifeq ($(BR2_PACKAGE_OPENSSL),y)
-MONIT_CONF_OPT += --with-ssl
+MONIT_CONF_OPT += --with-ssl=$(STAGING_DIR)/usr
 MONIT_DEPENDENCIES += openssl
 else
 MONIT_CONF_OPT += --without-ssl