package/asterisk: add optional libvorbis dependency
authorYann E. MORIN <yann.morin.1998@free.fr>
Sat, 9 Sep 2017 21:39:19 +0000 (23:39 +0200)
committerArnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Sat, 23 Sep 2017 17:20:18 +0000 (19:20 +0200)
Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
package/asterisk/asterisk.mk

index 1ac1f49c058a1e47506901254d1546643befc76b..82ca2ba73905394e2e93499bb50cde738cebe3cd 100644 (file)
@@ -103,7 +103,6 @@ ASTERISK_CONF_OPTS = \
        --without-tonezone \
        --without-unbound \
        --without-unixodbc \
-       --without-vorbis \
        --without-vpb \
        --without-x11 \
        --with-crypt \
@@ -188,6 +187,13 @@ else
 ASTERISK_CONF_OPTS += --without-speex  --without-speexdsp
 endif
 
+ifeq ($(BR2_PACKAGE_LIBVORBIS),y)
+ASTERISK_DEPENDENCIES += libvorbis
+ASTERISK_CONF_OPTS += --with-vorbis
+else
+ASTERISK_CONF_OPTS += --without-vorbis
+endif
+
 ifeq ($(BR2_PACKAGE_ZLIB),y)
 ASTERISK_DEPENDENCIES += zlib
 ASTERISK_CONF_OPTS += --with-z