package/openzwave: fix build with gcc 11
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Sun, 1 Aug 2021 12:29:09 +0000 (14:29 +0200)
committerYann E. MORIN <yann.morin.1998@free.fr>
Sun, 1 Aug 2021 18:47:07 +0000 (20:47 +0200)
Set DEBUG_FLAGS and RELEASE_FLAGS to an empty value to remove -Werror
and fix the following build failure with gcc 11:

/tmp/instance-5/output-1/build/openzwave-62444b0f979c337d2091d77d89cf63c2ae9775cf/cpp/src/command_classes/AssociationCommandConfiguration.cpp: In member function 'virtual bool OpenZWave::Internal::CC::AssociationCommandConfiguration::HandleMsg(const uint8*, uint32, uint32)':
/tmp/instance-5/output-1/build/openzwave-62444b0f979c337d2091d77d89cf63c2ae9775cf/cpp/src/command_classes/AssociationCommandConfiguration.cpp:191:85: error: 'this' pointer is null [-Werror=nonnull]
  191 |                                                                 group->ClearCommands(nodeIdx);
      |                                                                 ~~~~~~~~~~~~~~~~~~~~^~~~~~~~~

Fixes:
 - http://autobuild.buildroot.org/results/05ad5cc1f593704ef032f3c5278695247450b94b

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
package/openzwave/openzwave.mk

index 357d19f32e2e99963f9fb39b531f2b506e244bdc..9c28c0a13b4263bb94b6a2f9080c60850e265e07 100644 (file)
@@ -23,6 +23,7 @@ OPENZWAVE_INSTALL_STAGING = YES
 # the correct directory otherwise openzwave will install configuration files in
 # $(PREFIX)/etc/openzwave.
 # Disable doxygen documentation.
+# Set {DEBUG,RELEASE}_CFLAGS to an empty value to remove -Werror.
 OPENZWAVE_MAKE_OPTS = \
        CROSS_COMPILE="$(TARGET_CROSS)" \
        PREFIX=/usr \
@@ -30,6 +31,8 @@ OPENZWAVE_MAKE_OPTS = \
        pkgconfigdir=/usr/lib/pkgconfig \
        sysconfdir=/etc/openzwave \
        DOXYGEN= \
+       DEBUG_CFLAGS= \
+       RELEASE_CFLAGS= \
        USE_BI_TXML=0
 
 ifeq ($(BR2_PACKAGE_HAS_UDEV),y)