msmtp: add optional support for libgsasl
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Tue, 1 May 2018 19:01:32 +0000 (21:01 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Tue, 1 May 2018 19:25:51 +0000 (21:25 +0200)
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/msmtp/msmtp.mk

index a1bd9e1437c2a7a08fff1c12909e8237e8a8389e..b7a830649d403e50735f1147bf443c0b17aaaca0 100644 (file)
@@ -10,11 +10,17 @@ MSMTP_SOURCE = msmtp-$(MSMTP_VERSION).tar.xz
 MSMTP_DEPENDENCIES = host-pkgconf
 MSMTP_CONF_OPTS = \
        --without-libidn \
-       --disable-gai-idn \
-       --without-libgsasl
+       --disable-gai-idn
 MSMTP_LICENSE = GPL-3.0+
 MSMTP_LICENSE_FILES = COPYING
 
+ifeq ($(BR2_PACKAGE_LIBGSASL),y)
+MSMTP_CONF_OPTS += --with-libgsasl
+MSMTP_DEPENDENCIES += libgsasl
+else
+MSMTP_CONF_OPTS += --without-libgsasl
+endif
+
 ifeq ($(BR2_PACKAGE_LIBSECRET),y)
 MSMTP_CONF_OPTS += --with-libsecret
 MSMTP_DEPENDENCIES += libsecret