package/kodi: add CPE variables
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Sun, 16 May 2021 11:05:36 +0000 (13:05 +0200)
committerYann E. MORIN <yann.morin.1998@free.fr>
Sun, 16 May 2021 16:30:45 +0000 (18:30 +0200)
cpe:2.3:a:kodi:kodi is a valid CPE identifier for this package:

  https://nvd.nist.gov/products/cpe/search/results?namingFormat=2.3&keyword=cpe%3A2.3%3Aa%3Akodi%3Akodi

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
package/kodi/kodi.mk

index 47d3bd75c583b855a324d7b0b10290534a64156e..a5c9db1d7e7dbe121984e4bd7eb19cb39afc0392 100644 (file)
@@ -6,10 +6,14 @@
 
 # When updating the version, please also update kodi-jsonschemabuilder
 # and kodi-texturepacker
-KODI_VERSION = 19.1-Matrix
+KODI_VERSION_MAJOR = 19.1
+KODI_VERSION_NAME = Matrix
+KODI_VERSION = $(KODI_VERSION_MAJOR)-$(KODI_VERSION_NAME)
 KODI_SITE = $(call github,xbmc,xbmc,$(KODI_VERSION))
 KODI_LICENSE = GPL-2.0
 KODI_LICENSE_FILES = LICENSE.md
+KODI_CPE_ID_VENDOR = kodi
+KODI_CPE_ID_VERSION = $(KODI_VERSION_MAJOR)
 # needed for binary addons
 KODI_INSTALL_STAGING = YES
 # kodi recommends building out-of-source