package/ca-certificates: create ca-certificates.crt reproducibly
authorMartin Bark <martin@barkynet.com>
Sat, 16 Jun 2018 22:06:01 +0000 (23:06 +0100)
committerArnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Sun, 21 Oct 2018 13:36:32 +0000 (14:36 +0100)
Sort the certificates into alphabetical order so the contents of
ca-certificates.crt can be built reproducibly.

Note: The certificates are sorted uppercase then lowercase filenames
so the contents of ca-certificates.crt matches the source debian package.

Signed-off-by: Martin Bark <martin@barkynet.com>
Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
package/ca-certificates/ca-certificates.mk

index 1df9543e032c06146be9f8cfcd201c2424cbfbd2..5c259aa3abaa0460d6da7ad825afd3a321a6aedd 100644 (file)
@@ -31,7 +31,7 @@ define CA_CERTIFICATES_INSTALL_TARGET_CMDS
        # Create symlinks to certificates under /etc/ssl/certs
        # and generate the bundle
        cd $(TARGET_DIR) ;\
-       for i in `find usr/share/ca-certificates -name "*.crt"` ; do \
+       for i in `find usr/share/ca-certificates -name "*.crt" | LC_COLLATE=C sort` ; do \
                ln -sf ../../../$$i etc/ssl/certs/`basename $${i} .crt`.pem ;\
                cat $$i ;\
        done >$(@D)/ca-certificates.crt