package/cog: add config option to expose browser remote control on D-Bus system bus
authorAdrian Sweet <asweet@thegoodpenguin.co.uk>
Tue, 16 Mar 2021 09:47:27 +0000 (09:47 +0000)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Tue, 16 Mar 2021 21:04:02 +0000 (22:04 +0100)
Signed-off-by: Adrian Sweet <asweet@thegoodpenguin.co.uk>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/cog/Config.in
package/cog/cog.mk

index a9ca7473a9ab51e73108fc3d23928a1f43dd5113..5f00c5a2dd85f2f4f67da689e38f3c211852eea2 100644 (file)
@@ -47,6 +47,11 @@ config BR2_PACKAGE_COG_PLATFORM_DRM
          with video drivers that support kernel mode-setting (KMS)
          via the DRM user-space API.
 
+config BR2_PACKAGE_COG_USE_SYSTEM_DBUS
+       bool "expose system D-Bus control interface"
+       help
+         Expose remote control interface on system bus
+
 comment "DRM platform needs mesa3d w/ EGL driver and GBM"
        depends on !BR2_PACKAGE_MESA3D_OPENGL_EGL
 
index c7fc5e6feedc4bc40f789caca8a8012eb876cb58..86bdf935d247c3fa921f044d94ee4f09da1f77a4 100644 (file)
@@ -31,4 +31,10 @@ else
 COG_CONF_OPTS += -DCOG_PLATFORM_DRM=OFF
 endif
 
+ifeq ($(BR2_PACKAGE_COG_USE_SYSTEM_DBUS),y)
+COG_CONF_OPTS += -DCOG_DBUS_SYSTEM_BUS=ON
+else
+COG_CONF_OPTS += -DCOG_DBUS_SYSTEM_BUS=OFF
+endif
+
 $(eval $(cmake-package))