python-cheroot: new package
authorYegor Yefremov <yegorslists@googlemail.com>
Fri, 16 Jun 2017 07:27:57 +0000 (09:27 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 20 Jun 2017 19:54:27 +0000 (21:54 +0200)
Signed-off-by: Yegor Yefremov <yegorslists@googlemail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/Config.in
package/python-cheroot/Config.in [new file with mode: 0644]
package/python-cheroot/python-cheroot.hash [new file with mode: 0644]
package/python-cheroot/python-cheroot.mk [new file with mode: 0644]

index b852dd61fd5e054d93e024c09f658617f9cf7045..6bad95dfbdd1e13f7aa622395d3ae02f77673d3d 100644 (file)
@@ -696,6 +696,7 @@ menu "External python modules"
        source "package/python-characteristic/Config.in"
        source "package/python-chardet/Config.in"
        source "package/python-cheetah/Config.in"
+       source "package/python-cheroot/Config.in"
        source "package/python-cherrypy/Config.in"
        source "package/python-click/Config.in"
        source "package/python-coherence/Config.in"
diff --git a/package/python-cheroot/Config.in b/package/python-cheroot/Config.in
new file mode 100644 (file)
index 0000000..bb85f7b
--- /dev/null
@@ -0,0 +1,8 @@
+config BR2_PACKAGE_PYTHON_CHEROOT
+       bool "python-cheroot"
+       select BR2_PACKAGE_PYTHON_SIX # runtime
+       help
+         Cheroot is the high-performance, pure-Python
+         HTTP server used by CherryPy.
+
+         https://github.com/cherrypy/cheroot
diff --git a/package/python-cheroot/python-cheroot.hash b/package/python-cheroot/python-cheroot.hash
new file mode 100644 (file)
index 0000000..348b82d
--- /dev/null
@@ -0,0 +1,3 @@
+# md5 from https://pypi.python.org/pypi/cheroot/json, sha256 locally computed
+md5    e5503b0e67bdba29c6585965e7f42099  cheroot-5.5.0.tar.gz
+sha256 59e349f91b9230930f7078646bb92b3a5b0f9cf19a6ff949777409fd289a1eba  cheroot-5.5.0.tar.gz
diff --git a/package/python-cheroot/python-cheroot.mk b/package/python-cheroot/python-cheroot.mk
new file mode 100644 (file)
index 0000000..3f4b689
--- /dev/null
@@ -0,0 +1,15 @@
+################################################################################
+#
+# python-cheroot
+#
+################################################################################
+
+PYTHON_CHEROOT_VERSION = 5.5.0
+PYTHON_CHEROOT_SOURCE = cheroot-$(PYTHON_CHEROOT_VERSION).tar.gz
+PYTHON_CHEROOT_SITE = https://pypi.python.org/packages/a5/43/f8a461762dc62e9f273d4944fb8c140757c11a29c91c91d3fbd5fafb1570
+PYTHON_CHEROOT_LICENSE = BSD-3-Clause
+PYTHON_CHEROOT_LICENSE_FILES = LICENSE.md
+PYTHON_CHEROOT_SETUP_TYPE = setuptools
+PYTHON_CHEROOT_DEPENDENCIES = host-python-setuptools-scm
+
+$(eval $(python-package))