package/python{3}-cryptography: bump to version 3.3.2
authorJames Hilliard <james.hilliard1@gmail.com>
Thu, 8 Jul 2021 18:44:44 +0000 (12:44 -0600)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sat, 17 Jul 2021 08:09:18 +0000 (10:09 +0200)
This is the last version to support python2.

License hash change due to removal of OpenSSL locking reference:
https://github.com/pyca/cryptography/commit/49109ce1a6e870cb6cc87f05d9ae7c03d70a684b

Signed-off-by: James Hilliard <james.hilliard1@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/python-cryptography/python-cryptography.hash
package/python-cryptography/python-cryptography.mk
package/python3-cryptography/python3-cryptography.mk

index c6768ff21a57f2d76d6d6178f39016be07a47334..7cb38c8d3d2b2bf9c467f0f78c8e49c35064c39f 100644 (file)
@@ -1,7 +1,7 @@
 # md5, sha256 from https://pypi.org/pypi/cryptography/json
-md5  163608a7cb838c6b39360e1e64377d54  cryptography-3.0.tar.gz
-sha256  8e924dbc025206e97756e8903039662aa58aa9ba357d8e1d8fc29e3092322053  cryptography-3.0.tar.gz
+md5  e2ce2ec8a63965fad351f36ed70fde4b  cryptography-3.3.2.tar.gz
+sha256  5a60d3780149e13b7a6ff7ad6526b38846354d11a15e21068e57073e29e19bed  cryptography-3.3.2.tar.gz
 # Locally computed sha256 checksums
-sha256  35452b557fab0efb1e80d7edb9c4e5118b9384082adaa051dde342102cb9de8d  LICENSE
+sha256  43dad2cc752ab721cd9a9f36ece70fb53ab7713551f2d3d8694d8e8c5a06d6e2  LICENSE
 sha256  aac73b3148f6d1d7111dbca32099f68d26c644c6813ae1e4f05f6579aa2663fe  LICENSE.APACHE
 sha256  602c4c7482de6479dd2e9793cda275e5e63d773dacd1eca689232ab7008fb4fb  LICENSE.BSD
index eff0fa14a5a5bb7af1691ea53afcdc991b3364d4..98c65e152835bc1581a6c784bcb71f2ee906d8d7 100644 (file)
@@ -5,9 +5,9 @@
 ################################################################################
 
 # Please keep in sync with package/python3-cryptography/python3-cryptography.mk
-PYTHON_CRYPTOGRAPHY_VERSION = 3.0
+PYTHON_CRYPTOGRAPHY_VERSION = 3.3.2
 PYTHON_CRYPTOGRAPHY_SOURCE = cryptography-$(PYTHON_CRYPTOGRAPHY_VERSION).tar.gz
-PYTHON_CRYPTOGRAPHY_SITE = https://files.pythonhosted.org/packages/bf/ac/552fc8729d90393845cc3a2062facf4a89dcbe206fa78771d60ddaae7554
+PYTHON_CRYPTOGRAPHY_SITE = https://files.pythonhosted.org/packages/d4/85/38715448253404186029c575d559879912eb8a1c5d16ad9f25d35f7c4f4c
 PYTHON_CRYPTOGRAPHY_SETUP_TYPE = setuptools
 PYTHON_CRYPTOGRAPHY_LICENSE = Apache-2.0 or BSD-3-Clause
 PYTHON_CRYPTOGRAPHY_LICENSE_FILES = LICENSE LICENSE.APACHE LICENSE.BSD
index 03112e41d48b660033e3aefbb580068bf597a6fd..516864f3150b9aba274987ab8cf96ffaa28be14e 100644 (file)
@@ -5,9 +5,9 @@
 ################################################################################
 
 # Please keep in sync with package/python-cryptography/python-cryptography.mk
-PYTHON3_CRYPTOGRAPHY_VERSION = 3.0
+PYTHON3_CRYPTOGRAPHY_VERSION = 3.3.2
 PYTHON3_CRYPTOGRAPHY_SOURCE = cryptography-$(PYTHON3_CRYPTOGRAPHY_VERSION).tar.gz
-PYTHON3_CRYPTOGRAPHY_SITE = https://files.pythonhosted.org/packages/bf/ac/552fc8729d90393845cc3a2062facf4a89dcbe206fa78771d60ddaae7554
+PYTHON3_CRYPTOGRAPHY_SITE = https://files.pythonhosted.org/packages/d4/85/38715448253404186029c575d559879912eb8a1c5d16ad9f25d35f7c4f4c
 PYTHON3_CRYPTOGRAPHY_SETUP_TYPE = setuptools
 PYTHON3_CRYPTOGRAPHY_LICENSE = Apache-2.0 or BSD-3-Clause
 PYTHON3_CRYPTOGRAPHY_LICENSE_FILES = LICENSE LICENSE.APACHE LICENSE.BSD