netsnmp: install all MIB files
authorJulien Floret <julien.floret@6wind.com>
Fri, 8 Sep 2017 13:45:48 +0000 (15:45 +0200)
committerArnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Wed, 13 Sep 2017 21:23:40 +0000 (23:23 +0200)
Since commit be8e32d585f3 ("netsnmp: configurable MIB modules"),
the list of MIB modules can be selected with a configuration option.

However, there was still an hardcoded list of MIB files to exclude from
the target filesystem.
Since it is complicated to know which MIB files are necessary according
to the configuration, let's install all of them.

Cc: przemyslaw <przemyslaw.wrzos@calyptech.com>
Cc: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Julien Floret <julien.floret@6wind.com>
Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
package/netsnmp/netsnmp.mk

index abcf63d568580fe1deb2b01b1e0f02ce7f53a873..742fa6e3b38290d081c6ed2796438fa15d71e27e 100644 (file)
@@ -38,8 +38,6 @@ NETSNMP_MAKE = $(MAKE1)
 NETSNMP_CONFIG_SCRIPTS = net-snmp-config
 NETSNMP_AUTORECONF = YES
 
-NETSNMP_BLOAT_MIBS = BRIDGE DISMAN-EVENT DISMAN-SCHEDULE DISMAN-SCRIPT EtherLike RFC-1215 RFC1155-SMI RFC1213 SCTP SMUX
-
 ifeq ($(BR2_ENDIAN),"BIG")
 NETSNMP_CONF_OPTS += --with-endianness=big
 else
@@ -101,14 +99,6 @@ else
 NETSNMP_CONF_OPTS += --disable-applications
 endif
 
-define NETSNMP_REMOVE_BLOAT_MIBS
-       for mib in $(NETSNMP_BLOAT_MIBS); do \
-               rm -f $(TARGET_DIR)/usr/share/snmp/mibs/$$mib-MIB.txt; \
-       done
-endef
-
-NETSNMP_POST_INSTALL_TARGET_HOOKS += NETSNMP_REMOVE_BLOAT_MIBS
-
 ifeq ($(BR2_PACKAGE_NETSNMP_SERVER),y)
 define NETSNMP_INSTALL_INIT_SYSV
        $(INSTALL) -D -m 0755 package/netsnmp/S59snmpd \