Makefile: release: create tarball from current branch, not master
authorPeter Korsgaard <jacmet@sunsite.dk>
Tue, 17 Sep 2013 11:42:07 +0000 (13:42 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Tue, 17 Sep 2013 12:00:04 +0000 (14:00 +0200)
To support stable bugfix releases.

Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Makefile

index 2163e95a52e1c0405d32958249d91a281e6214dd..6ef0edc2bb2e8c319184b634b38ffa59c1834e50 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -838,7 +838,7 @@ release: OUT=buildroot-$(BR2_VERSION)
 # Create release tarballs. We need to fiddle a bit to add the generated
 # documentation to the git output
 release:
-       git archive --format=tar --prefix=$(OUT)/ master > $(OUT).tar
+       git archive --format=tar --prefix=$(OUT)/ HEAD > $(OUT).tar
        $(MAKE) O=$(OUT) manual-html manual-txt manual-pdf
        tar rf $(OUT).tar $(OUT)
        gzip -9 -c < $(OUT).tar > $(OUT).tar.gz