erlang: remove non-SMP build option
authorFrank Hunleth <fhunleth@troodon-software.com>
Wed, 20 Dec 2017 14:32:39 +0000 (09:32 -0500)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Thu, 28 Dec 2017 22:25:43 +0000 (23:25 +0100)
The non-SMP scheduler was deprecated with the Erlang/OTP 20.0 release and
slated for removal with the next major Erlang release. Since the non-SMP
scheduler isn't even built anymore, this option no longer has the
intended effect of saving space or compile time. The SMP scheduler
supports both SMP and non-SMP processors, so removing the option will
not break any platforms.

We do not need to add a legacy entry, because the new behavior is the
same as with the option previously set (i.e. SMP enabled).

Signed-off-by: Frank Hunleth <fhunleth@troodon-software.com>
Acked-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/erlang/Config.in
package/erlang/erlang.mk

index 1cd93ca9558668e64c8bbfd1cbc8681f02a8f831..96af5516fd0ec835bdb9d703dd9da6f60a18daca 100644 (file)
@@ -27,16 +27,6 @@ config BR2_PACKAGE_ERLANG
 
 if BR2_PACKAGE_ERLANG
 
-config BR2_PACKAGE_ERLANG_SMP
-       bool "enable SMP support"
-       help
-         Erlang provides both a UP and an SMP emulator. The UP
-         emulator is always built, and this option enables
-         compilation of the SMP emulator. The choice of which
-         emulator to use is made at runtime. If you do not need SMP
-         support, turning this option off reduces compile time and
-         the size of the Erlang installation.
-
 config BR2_PACKAGE_ERLANG_MEGACO
        bool "install megaco application"
        help
index 733c1d5786c4bb6a37b52dd0f2c2581adf4b57ad..5705b98d8ee81d85b0bc1308b11b4314e8574a56 100644 (file)
@@ -74,10 +74,6 @@ ERLANG_CONF_OPTS += --enable-shared-zlib
 ERLANG_DEPENDENCIES += zlib
 endif
 
-ifeq ($(BR2_PACKAGE_ERLANG_SMP),)
-ERLANG_CONF_OPTS += --disable-smp-support
-endif
-
 # Remove source, example, gs and wx files from staging and target.
 ERLANG_REMOVE_PACKAGES = gs wx