package/cairo: add optional support for lzo
authorBernd Kuhls <bernd.kuhls@t-online.de>
Sun, 21 Feb 2016 14:47:29 +0000 (15:47 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 21 Feb 2016 15:04:14 +0000 (16:04 +0100)
When lzo was compiled before, cairo will use it as optional dependency:

$ output/host/usr/bin/x86_64-linux-readelf -a output/target/usr/bin/cairo-sphinx | grep NEEDED | sort
[...]
 0x0000000000000001 (NEEDED)             Shared library: [liblzo2.so.2]

The build system offers no option to en-/disable lzo support:
https://cgit.freedesktop.org/cairo/tree/configure.ac#n54

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/cairo/cairo.mk

index 205250d95013492cef4e467e4310a460412e48c7..6b54b286e187838b44f2024634e3da68e63614c2 100644 (file)
@@ -93,6 +93,10 @@ else
 CAIRO_CONF_OPTS += --disable-vg
 endif
 
+ifeq ($(BR2_PACKAGE_LZO),y)
+CAIRO_DEPENDENCIES += lzo
+endif
+
 ifeq ($(BR2_PACKAGE_XORG7),y)
 CAIRO_CONF_OPTS += --enable-xlib --enable-xcb --with-x
 CAIRO_DEPENDENCIES += xlib_libX11 xlib_libXext