gpm: avoid use of host emacs
authorBaruch Siach <baruch@tkos.co.il>
Fri, 27 Feb 2015 12:20:00 +0000 (14:20 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Fri, 27 Feb 2015 13:47:53 +0000 (14:47 +0100)
configure looks for emacs installation to byte compile .el files. This may
break the build if the host installed emacs is missing needed dependencies.
Since we don't (yet?) package emacs for target, just disable detection of
emacs.

Signed-off-by: Baruch Siach <baruch@tkos.co.il>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/gpm/gpm.mk

index dcf075a9c636047d1d53ab5f45ecd03b8e75fe40..dee6208113083bb2bbd5cab6c28b343d37aa931a 100644 (file)
@@ -15,7 +15,8 @@ GPM_DEPENDENCIES = host-bison
 # if not already installed in staging dir, gpm Makefile may fail to find some
 # of the headers needed to generate build dependencies, the first time it is
 # built. CPPFLAGS is used to pass the right include path to dependency rules.
-GPM_CONF_ENV = CPPFLAGS="$(TARGET_CPPFLAGS) -I$(@D)/src/headers/"
+GPM_CONF_ENV = CPPFLAGS="$(TARGET_CPPFLAGS) -I$(@D)/src/headers/" \
+                          ac_cv_path_emacs=no
 
 # For some reason, Microblaze gcc does not define __ELF__, which gpm
 # configure script uses to determine whether the architecture uses ELF