libsigsegv: fix avr32 build
authorSimon Dawson <spdawson@gmail.com>
Tue, 5 Nov 2013 07:43:29 +0000 (07:43 +0000)
committerPeter Korsgaard <peter@korsgaard.com>
Tue, 5 Nov 2013 07:58:10 +0000 (08:58 +0100)
The libsigsegv configure step fails to correctly figure out the direction of
stack growth for avr32. This leads to a zero STACK_DIRECTION definition, and
build failures such as the following.

  http://autobuild.buildroot.net/results/a3fe938f9376533b4777d79deb7a2ee83ed5ce33

Signed-off-by: Simon Dawson <spdawson@gmail.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/libsigsegv/libsigsegv-0001-fix-avr32-build.patch [new file with mode: 0644]
package/libsigsegv/libsigsegv.mk

diff --git a/package/libsigsegv/libsigsegv-0001-fix-avr32-build.patch b/package/libsigsegv/libsigsegv-0001-fix-avr32-build.patch
new file mode 100644 (file)
index 0000000..f585764
--- /dev/null
@@ -0,0 +1,20 @@
+The libsigsegv configure step fails to correctly figure out the direction of
+stack growth for avr32. This leads to a zero STACK_DIRECTION definition, and
+build failures such as the following.
+
+  http://autobuild.buildroot.net/results/a3fe938f9376533b4777d79deb7a2ee83ed5ce33
+
+Signed-off-by: Simon Dawson <spdawson@gmail.com>
+
+diff -Nurp a/m4/stack-direction.m4 b/m4/stack-direction.m4
+--- a/m4/stack-direction.m4    2009-11-21 12:22:45.000000000 +0000
++++ b/m4/stack-direction.m4    2013-11-04 09:29:27.558036038 +0000
+@@ -16,7 +16,7 @@ AC_DEFUN([SV_STACK_DIRECTION],
+       alpha* | \
+       arc | \
+       arm* | strongarm* | xscale* | \
+-      avr | \
++      avr | avr32 | \
+       c1 | c2 | c32 | c34 | c38 | \
+       clipper | \
+       cris | \
index 2cc2544c016f7a088b3b0972dbb9ac0d3ca6f892..a5bb31c9cf5c5701282bfe5fba4f660cc2d25be1 100644 (file)
@@ -11,4 +11,6 @@ LIBSIGSEGV_CONF_ENV = sv_cv_fault_posix=yes
 LIBSIGSEGV_LICENSE = GPLv2+
 LIBSIGSEGV_LICENSE_FILES = COPYING
 
+LIBSIGSEGV_AUTORECONF = YES
+
 $(eval $(autotools-package))